# CVE-2014-0003: Apache Camel's XSLT component allows remote attackers to execute arbitrary Java methods

> Remote attackers can execute arbitrary Java methods in Apache Camel via crafted messages, requiring immediate upgrades to secure integration flows.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-h6rp-8v4j-hwph

## What is CVE-2014-0003?

CVE-2014-0003 is a high-severity code injection vulnerability in Apache Camel, published on 20 Mar 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The XSLT component in Apache Camel 2.11.x before 2.11.4, 2.12.x before 2.12.3, and possibly earlier versions allows remote attackers to execute arbitrary Java methods via a crafted message.

Weakness: CWE-264

## Which versions are affected by CVE-2014-0003?

4 open source packages ship an affected version, including org.apache.camel:camel-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-core` | Maven | From 2.11.0 | 2.11.4 |
| `org.apache.camel:camel-core` | Maven | From 2.11.0 | 2.11.4 |
| `org.apache.camel:camel-core` | Maven | From 2.12.0 | 2.12.3 |
| `org.apache.camel:camel-core` | Maven | From 2.12.0 | 2.12.3 |

Products: Apache Camel.

## How do I fix CVE-2014-0003?

Upgrade org.apache.camel:camel-core to a fixed version for your release line: 2.11.4 or 2.12.3.

## Is CVE-2014-0003 being exploited?

There is no known exploitation of CVE-2014-0003 in the wild and no public exploit code.

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0003 and fix it if it is affected.

What it is: CVE-2014-0003 is a high-severity code injection vulnerability in Apache Camel, published on 20 Mar 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0003 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-core (Maven): affected from 2.11.0; fixed in 2.11.4
- org.apache.camel:camel-core (Maven): affected from 2.11.0; fixed in 2.11.4
- org.apache.camel:camel-core (Maven): affected from 2.12.0; fixed in 2.12.3
- org.apache.camel:camel-core (Maven): affected from 2.12.0; fixed in 2.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0003/ (Markdown: https://insights.sbomify.com/CVE-2014-0003/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0003
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0003
- OSV: https://osv.dev/vulnerability/CVE-2014-0003

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0003/
Summaries are generated and may contain mistakes; the official description above is the record.
