# CVE-2014-0006: OpenStack Swift Discloses Secret URLs to Timing Attack

> Remote attackers can obtain secret URLs in OpenStack Swift via a timing side-channel attack, leading to unauthorized data access.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-0006, GHSA-cf9m-q836-vf26, PYSEC-2014-116, RHSA-2014:0232, RHSA-2014:0367

## What is CVE-2014-0006?

CVE-2014-0006 is a medium-severity vulnerability in n/a, published on 23 Jan 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The TempURL middleware in OpenStack Object Storage (Swift) 1.4.6 through 1.8.0, 1.9.0 through 1.10.0, and 1.11.0 allows remote attackers to obtain secret URLs by leveraging an object name and a timing side-channel attack.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-0006?

7 open source packages ship an affected version, including swift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swift` | PyPI | From 1.11.0 | 1.12.0 |
| `swift` | PyPI | From 1.11.0 | 1.12.0 |
| `swift` | PyPI | From 1.4.6 to 1.8.0 | None |
| `swift` | PyPI | From 1.4.6 to 1.8.0 | None |
| `swift` | PyPI | From 1.4.6 | 1.12.0 |
| `swift` | PyPI | From 1.9.0 to 1.10.0 | None |
| `swift` | PyPI | From 1.9.0 to 1.10.0 | None |
| `openstack-swift` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-8.el6ost |
| `openstack-swift-account` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-8.el6ost |
| `openstack-swift-container` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-8.el6ost |
| `openstack-swift-doc` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-8.el6ost |
| `openstack-swift-object` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-8.el6ost |
| `openstack-swift-proxy` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-8.el6ost |
| `openstack-swift` | Red Hat:openstack:4::el6 | All versions | 0:1.10.0-3.el6ost |
| `openstack-swift-account` | Red Hat:openstack:4::el6 | All versions | 0:1.10.0-3.el6ost |
| `openstack-swift-container` | Red Hat:openstack:4::el6 | All versions | 0:1.10.0-3.el6ost |
| `openstack-swift-doc` | Red Hat:openstack:4::el6 | All versions | 0:1.10.0-3.el6ost |
| `openstack-swift-object` | Red Hat:openstack:4::el6 | All versions | 0:1.10.0-3.el6ost |
| `openstack-swift-proxy` | Red Hat:openstack:4::el6 | All versions | 0:1.10.0-3.el6ost |

Products: Openstack Swift.

## How do I fix CVE-2014-0006?

Upgrade swift to 1.12.0 or later.

## Is CVE-2014-0006 being exploited?

There is no known exploitation of CVE-2014-0006 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-0737](https://insights.sbomify.com/CVE-2016-0737/): OpenStack Object Storage (Swift) allows remote attackers to cause a denial of service (high 7.5)
- [CVE-2016-0738](https://insights.sbomify.com/CVE-2016-0738/): OpenStack Object Storage (Swift) allows remote attackers to cause a denial of service (high 7.5)
- [CVE-2026-49017](https://insights.sbomify.com/CVE-2026-49017/): OpenStack Swift: s3api middleware enters an infinite loop when processing a truncated aws-chunked PUT request body (high 7.1)
- [CVE-2013-6396](https://insights.sbomify.com/CVE-2013-6396/): Python Swift client is vulnerable to Missing SSL Certificate Check (medium 5.8)
- [CVE-2026-50221](https://insights.sbomify.com/CVE-2026-50221/): OpenStack Swift vulnerable to authenticated server-side request forgery (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0006 and fix it if it is affected.

What it is: CVE-2014-0006 is a medium-severity vulnerability in n/a, published on 23 Jan 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0006 in the wild and no public exploit code.

Affected packages and fixed versions:
- swift (PyPI): affected from 1.11.0; fixed in 1.12.0
- swift (PyPI): affected from 1.11.0; fixed in 1.12.0
- swift (PyPI): affected from 1.4.6 up to 1.8.0; no fix listed
- swift (PyPI): affected from 1.4.6 up to 1.8.0; no fix listed
- swift (PyPI): affected from 1.4.6; fixed in 1.12.0
- swift (PyPI): affected from 1.9.0 up to 1.10.0; no fix listed
- swift (PyPI): affected from 1.9.0 up to 1.10.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0006/ (Markdown: https://insights.sbomify.com/CVE-2014-0006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0006
- OSV: https://osv.dev/vulnerability/CVE-2014-0006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0006/
Summaries are generated and may contain mistakes; the official description above is the record.
