CVE-2014-0013 Ember.js Cross-site Scripting vulnerability
Remote attackers can execute arbitrary scripts via XSS in Ember.js applications using specific Handlebars templates with user-supplied primitive contexts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-0013?
CVE-2014-0013 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Feb 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging an application that contains templates whose context is set to a user-supplied primitive value and also contain the `{{this}}` special Handlebars variable.
Weakness: CWE-79
Which versions are affected by CVE-2014-0013?
10 open source packages ship an affected version, including ember-source. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
ember-source RubyGems | From 1.0.0.pre4.0 | 1.0.1 |
ember-source RubyGems | From 1.0.0.pre4.0 | 1.0.1 |
ember-source RubyGems | From 1.1.0 | 1.1.3 |
ember-source RubyGems | From 1.1.0 | 1.1.3 |
ember-source RubyGems | From 1.2.0.beta.1 | 1.2.1 |
ember-source RubyGems | From 1.2.0.beta.1 | 1.2.1 |
4 more packages
ember-source RubyGems | From 1.3.0.beta.1 | 1.3.1 |
ember-source RubyGems | From 1.3.0.beta.1 | 1.3.1 |
ember-source RubyGems | From 1.4.0-beta.1 | 1.4.0-beta.2 |
ember-source RubyGems | From 1.4.0-beta.1 | 1.4.0-beta.2 |
Products include Emberjs Ember.js.
How do I fix CVE-2014-0013?
Upgrade ember-source to a fixed version for your release line: 1.0.1, 1.1.3, 1.2.1 or 1.3.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-0013 being exploited?
There is no known exploitation of CVE-2014-0013 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2013-4170 Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data
- CVE-2015-1866 ember-source vulnerable to Cross-site Scripting
- CVE-2015-7565 ember-source Cross-site Scripting vulnerability
- CVE-2014-0014 ember-source Cross-site Scripting vulnerability
- CVE-2014-0046 ember-source Cross-site Scripting vulnerability
Sources
Also known as GHSA-8xm3-gm7c-5fjx.