{"answers":{"affected":"10 open source packages ship an affected version, including ember-source. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-0013 in the wild and no public exploit code.","fix":"Upgrade ember-source to a fixed version for your release line: 1.0.1, 1.1.3, 1.2.1 or 1.3.1.","what":"CVE-2014-0013 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Feb 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-0013 and fix it if it is affected.\n\nWhat it is: CVE-2014-0013 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Feb 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-0013 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ember-source (RubyGems): affected from 1.0.0.pre4.0; fixed in 1.0.1\n- ember-source (RubyGems): affected from 1.0.0.pre4.0; fixed in 1.0.1\n- ember-source (RubyGems): affected from 1.1.0; fixed in 1.1.3\n- ember-source (RubyGems): affected from 1.1.0; fixed in 1.1.3\n- ember-source (RubyGems): affected from 1.2.0.beta.1; fixed in 1.2.1\n- ember-source (RubyGems): affected from 1.2.0.beta.1; fixed in 1.2.1\n- ember-source (RubyGems): affected from 1.3.0.beta.1; fixed in 1.3.1\n- ember-source (RubyGems): affected from 1.3.0.beta.1; fixed in 1.3.1\n- ember-source (RubyGems): affected from 1.4.0-beta.1; fixed in 1.4.0-beta.2\n- ember-source (RubyGems): affected from 1.4.0-beta.1; fixed in 1.4.0-beta.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0013/ (Markdown: https://insights.sbomify.com/CVE-2014-0013/index.md)","id":"CVE-2014-0013","markdown":"https://insights.sbomify.com/CVE-2014-0013/index.md","name":"CVE-2014-0013","record":{"aliases":["GHSA-8xm3-gm7c-5fjx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ember.js JavaScript library","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via XSS in Ember.js applications using specific Handlebars templates with user-supplied primitive contexts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ember.js","vendor":"emberjs"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging an application that contains templates whose context is set to a user-supplied primitive value and also contain the `{{this}}` special Handlebars variable.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ember.js Cross-site Scripting vulnerability","id":"CVE-2014-0013","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2014"},"n_packages":10,"n_references":2,"next":{"headline":"ember-source Cross-site Scripting vulnerability","id":"CVE-2014-0014"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.1"],"introduced":["1.0.0.pre4.0"],"last_affected":[],"package":"ember-source","purl":null,"source":"GHSA-8xm3-gm7c-5fjx"},{"ecosystem":"RubyGems","fixed":["1.0.1"],"introduced":["1.0.0.pre4.0"],"last_affected":[],"package":"ember-source","purl":"pkg:gem/ember-source","source":"GHSA-8xm3-gm7c-5fjx"},{"ecosystem":"RubyGems","fixed":["1.1.3"],"introduced":["1.1.0"],"last_affected":[],"package":"ember-source","purl":null,"source":"GHSA-8xm3-gm7c-5fjx"},{"ecosystem":"RubyGems","fixed":["1.1.3"],"introduced":["1.1.0"],"last_affected":[],"package":"ember-source","purl":"pkg:gem/ember-source","source":"GHSA-8xm3-gm7c-5fjx"},{"ecosystem":"RubyGems","fixed":["1.2.1"],"introduced":["1.2.0.beta.1"],"last_affected":[],"package":"ember-source","purl":null,"source":"GHSA-8xm3-gm7c-5fjx"},{"ecosystem":"RubyGems","fixed":["1.2.1"],"introduced":["1.2.0.beta.1"],"last_affected":[],"package":"ember-source","purl":"pkg:gem/ember-source","source":"GHSA-8xm3-gm7c-5fjx"},{"ecosystem":"RubyGems","fixed":["1.3.1"],"introduced":["1.3.0.beta.1"],"last_affected":[],"package":"ember-source","purl":null,"source":"GHSA-8xm3-gm7c-5fjx"},{"ecosystem":"RubyGems","fixed":["1.3.1"],"introduced":["1.3.0.beta.1"],"last_affected":[],"package":"ember-source","purl":"pkg:gem/ember-source","source":"GHSA-8xm3-gm7c-5fjx"},{"ecosystem":"RubyGems","fixed":["1.4.0-beta.2"],"introduced":["1.4.0-beta.1"],"last_affected":[],"package":"ember-source","purl":null,"source":"GHSA-8xm3-gm7c-5fjx"},{"ecosystem":"RubyGems","fixed":["1.4.0-beta.2"],"introduced":["1.4.0-beta.1"],"last_affected":[],"package":"ember-source","purl":"pkg:gem/ember-source","source":"GHSA-8xm3-gm7c-5fjx"}],"prev":{"headline":"Insecure Temporary File in Jinja2","id":"CVE-2014-0012"},"products":["n/a"],"published":"2018-02-15","related":[{"cvss_score":6.1,"headline":"Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data","id":"CVE-2013-4170","kev_date_added":null,"published":"2022-06-30"},{"cvss_score":6.1,"headline":"ember-source vulnerable to Cross-site Scripting","id":"CVE-2015-1866","kev_date_added":null,"published":"2017-09-20"},{"cvss_score":6.1,"headline":"ember-source Cross-site Scripting vulnerability","id":"CVE-2015-7565","kev_date_added":null,"published":"2017-04-13"},{"cvss_score":5.4,"headline":"ember-source Cross-site Scripting vulnerability","id":"CVE-2014-0014","kev_date_added":null,"published":"2018-02-15"},{"cvss_score":2.6,"headline":"ember-source Cross-site Scripting vulnerability","id":"CVE-2014-0046","kev_date_added":null,"published":"2014-02-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary scripts via XSS in Ember.js applications using specific Handlebars templates with user-supplied primitive contexts.","url":"https://insights.sbomify.com/CVE-2014-0013/"}