# CVE-2014-0013: Ember.js Cross-site Scripting vulnerability

> Remote attackers can execute arbitrary scripts via XSS in Ember.js applications using specific Handlebars templates with user-supplied primitive contexts.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Feb 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-8xm3-gm7c-5fjx

## What is CVE-2014-0013?

CVE-2014-0013 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Feb 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging an application that contains templates whose context is set to a user-supplied primitive value and also contain the `{{this}}` special Handlebars variable.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-0013?

10 open source packages ship an affected version, including ember-source. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ember-source` | RubyGems | From 1.0.0.pre4.0 | 1.0.1 |
| `ember-source` | RubyGems | From 1.0.0.pre4.0 | 1.0.1 |
| `ember-source` | RubyGems | From 1.1.0 | 1.1.3 |
| `ember-source` | RubyGems | From 1.1.0 | 1.1.3 |
| `ember-source` | RubyGems | From 1.2.0.beta.1 | 1.2.1 |
| `ember-source` | RubyGems | From 1.2.0.beta.1 | 1.2.1 |
| `ember-source` | RubyGems | From 1.3.0.beta.1 | 1.3.1 |
| `ember-source` | RubyGems | From 1.3.0.beta.1 | 1.3.1 |
| `ember-source` | RubyGems | From 1.4.0-beta.1 | 1.4.0-beta.2 |
| `ember-source` | RubyGems | From 1.4.0-beta.1 | 1.4.0-beta.2 |

Products: Emberjs Ember.js.

## How do I fix CVE-2014-0013?

Upgrade ember-source to a fixed version for your release line: 1.0.1, 1.1.3, 1.2.1 or 1.3.1.

## Is CVE-2014-0013 being exploited?

There is no known exploitation of CVE-2014-0013 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-4170](https://insights.sbomify.com/CVE-2013-4170/): Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data (medium 6.1)
- [CVE-2015-1866](https://insights.sbomify.com/CVE-2015-1866/): ember-source vulnerable to Cross-site Scripting (medium 6.1)
- [CVE-2015-7565](https://insights.sbomify.com/CVE-2015-7565/): ember-source Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2014-0014](https://insights.sbomify.com/CVE-2014-0014/): ember-source Cross-site Scripting vulnerability (medium 5.4)
- [CVE-2014-0046](https://insights.sbomify.com/CVE-2014-0046/): ember-source Cross-site Scripting vulnerability (low 2.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0013 and fix it if it is affected.

What it is: CVE-2014-0013 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Feb 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-0013 in the wild and no public exploit code.

Affected packages and fixed versions:
- ember-source (RubyGems): affected from 1.0.0.pre4.0; fixed in 1.0.1
- ember-source (RubyGems): affected from 1.0.0.pre4.0; fixed in 1.0.1
- ember-source (RubyGems): affected from 1.1.0; fixed in 1.1.3
- ember-source (RubyGems): affected from 1.1.0; fixed in 1.1.3
- ember-source (RubyGems): affected from 1.2.0.beta.1; fixed in 1.2.1
- ember-source (RubyGems): affected from 1.2.0.beta.1; fixed in 1.2.1
- ember-source (RubyGems): affected from 1.3.0.beta.1; fixed in 1.3.1
- ember-source (RubyGems): affected from 1.3.0.beta.1; fixed in 1.3.1
- ember-source (RubyGems): affected from 1.4.0-beta.1; fixed in 1.4.0-beta.2
- ember-source (RubyGems): affected from 1.4.0-beta.1; fixed in 1.4.0-beta.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0013/ (Markdown: https://insights.sbomify.com/CVE-2014-0013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0013
- OSV: https://osv.dev/vulnerability/CVE-2014-0013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0013/
Summaries are generated and may contain mistakes; the official description above is the record.
