{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-0022 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2014-0022 is a medium-severity vulnerability in n/a, published on 26 Jan 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0022 and fix it if it is affected.\n\nWhat it is: CVE-2014-0022 is a medium-severity vulnerability in n/a, published on 26 Jan 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-0022 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0022/ (Markdown: https://insights.sbomify.com/CVE-2014-0022/index.md)","id":"CVE-2014-0022","markdown":"https://insights.sbomify.com/CVE-2014-0022/index.md","name":"CVE-2014-0022","record":{"aliases":["GHSA-f9cg-v6pq-9w58","RHSA-2014:1004","UBUNTU-CVE-2014-0022"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Linux package manager","requires_auth":"none","summary":"Remote attackers can bypass RPM package signing restrictions in yum-cron by installing unsigned packages due to improper return value checking.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"yum","vendor":"baseurl"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The installUpdates function in yum-cron/yum-cron.py in yum 3.4.3 and earlier does not properly check the return value of the sigCheckPkg function, which allows remote attackers to bypass the RMP package signing restriction via an unsigned package.","ecosystems":["Red Hat:enterprise_linux:5::client","Red Hat:enterprise_linux:5::server"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in n/a","id":"CVE-2014-0022","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2014"},"n_packages":2,"n_references":5,"next":{"headline":"Other in OpenShift","id":"CVE-2014-0023"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:5::client","fixed":["1:0.9-6.el5_10"],"introduced":["0"],"last_affected":[],"package":"yum-updatesd","purl":"pkg:rpm/redhat/yum-updatesd","source":"RHSA-2014:1004"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["1:0.9-6.el5_10"],"introduced":["0"],"last_affected":[],"package":"yum-updatesd","purl":"pkg:rpm/redhat/yum-updatesd","source":"RHSA-2014:1004"}],"prev":{"headline":"Denial of service in Chrony","id":"CVE-2014-0021"},"products":["n/a"],"published":"2014-01-26","related":[{"cvss_score":9.8,"headline":"Denial of service in yum","id":"CVE-2013-1910","kev_date_added":null,"published":"2019-10-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass RPM package signing restrictions in yum-cron by installing unsigned packages due to improper return value checking.","url":"https://insights.sbomify.com/CVE-2014-0022/"}