CVE-2014-0046 ember-source Cross-site Scripting vulnerability

Low 2.6 Published Updated

Remote attackers can inject arbitrary web script or HTML via the title attribute in the link-to helper, requiring user interaction to execute.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2014-0046?

CVE-2014-0046 is a low-severity cross-site scripting vulnerability in n/a, published on 27 Feb 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before 1.4.0-beta.6, when used in non-block form, allows remote attackers to inject arbitrary web script or HTML via the title attribute.

Weakness: CWE-79

Which versions are affected by CVE-2014-0046?

6 open source packages ship an affected version, including ember-source. It affects 1 product.

PackageAffectedFixed in
ember-source RubyGemsFrom 1.2.01.2.2
ember-source RubyGemsFrom 1.2.01.2.2
ember-source RubyGemsFrom 1.3.01.3.2
ember-source RubyGemsFrom 1.3.01.3.2
ember-source RubyGemsFrom 1.4.0.beta.11.4.0.beta.6
ember-source RubyGemsFrom 1.4.0.beta.11.4.0.beta.6

Products include Emberjs Ember.js.

How do I fix CVE-2014-0046?

Upgrade ember-source to a fixed version for your release line: 1.2.2, 1.3.2 or 1.4.0.beta.6.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2014-0046 being exploited?

There is no known exploitation of CVE-2014-0046 in the wild and no public exploit code.

Sources

Also known as GHSA-4q53-fqhc-cr46.

Is CVE-2014-0046 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free