{"answers":{"affected":"6 open source packages ship an affected version, including ember-source. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-0046 in the wild and no public exploit code.","fix":"Upgrade ember-source to a fixed version for your release line: 1.2.2, 1.3.2 or 1.4.0.beta.6.","what":"CVE-2014-0046 is a low-severity cross-site scripting vulnerability in n/a, published on 27 Feb 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-0046 and fix it if it is affected.\n\nWhat it is: CVE-2014-0046 is a low-severity cross-site scripting vulnerability in n/a, published on 27 Feb 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-0046 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ember-source (RubyGems): affected from 1.2.0; fixed in 1.2.2\n- ember-source (RubyGems): affected from 1.2.0; fixed in 1.2.2\n- ember-source (RubyGems): affected from 1.3.0; fixed in 1.3.2\n- ember-source (RubyGems): affected from 1.3.0; fixed in 1.3.2\n- ember-source (RubyGems): affected from 1.4.0.beta.1; fixed in 1.4.0.beta.6\n- ember-source (RubyGems): affected from 1.4.0.beta.1; fixed in 1.4.0.beta.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0046/ (Markdown: https://insights.sbomify.com/CVE-2014-0046/index.md)","id":"CVE-2014-0046","markdown":"https://insights.sbomify.com/CVE-2014-0046/index.md","name":"CVE-2014-0046","record":{"aliases":["GHSA-4q53-fqhc-cr46"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript framework","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the title attribute in the link-to helper, requiring user interaction to execute.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ember.js","vendor":"emberjs"}],"cvss":{"score":2.6,"severity":"low","source":"nvd","vector":"AV:N/AC:H/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before 1.4.0-beta.6, when used in non-block form, allows remote attackers to inject arbitrary web script or HTML via the title attribute.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ember-source Cross-site Scripting vulnerability","id":"CVE-2014-0046","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2014"},"n_packages":6,"n_references":6,"next":{"headline":"Path traversal in n/a","id":"CVE-2014-0047"},"packages":[{"ecosystem":"RubyGems","fixed":["1.2.2"],"introduced":["1.2.0"],"last_affected":[],"package":"ember-source","purl":null,"source":"GHSA-4q53-fqhc-cr46"},{"ecosystem":"RubyGems","fixed":["1.2.2"],"introduced":["1.2.0"],"last_affected":[],"package":"ember-source","purl":"pkg:gem/ember-source","source":"GHSA-4q53-fqhc-cr46"},{"ecosystem":"RubyGems","fixed":["1.3.2"],"introduced":["1.3.0"],"last_affected":[],"package":"ember-source","purl":null,"source":"GHSA-4q53-fqhc-cr46"},{"ecosystem":"RubyGems","fixed":["1.3.2"],"introduced":["1.3.0"],"last_affected":[],"package":"ember-source","purl":"pkg:gem/ember-source","source":"GHSA-4q53-fqhc-cr46"},{"ecosystem":"RubyGems","fixed":["1.4.0.beta.6"],"introduced":["1.4.0.beta.1"],"last_affected":[],"package":"ember-source","purl":null,"source":"GHSA-4q53-fqhc-cr46"},{"ecosystem":"RubyGems","fixed":["1.4.0.beta.6"],"introduced":["1.4.0.beta.1"],"last_affected":[],"package":"ember-source","purl":"pkg:gem/ember-source","source":"GHSA-4q53-fqhc-cr46"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2014-0045"},"products":["n/a"],"published":"2014-02-27","related":[{"cvss_score":6.1,"headline":"Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data","id":"CVE-2013-4170","kev_date_added":null,"published":"2022-06-30"},{"cvss_score":6.1,"headline":"ember-source vulnerable to Cross-site Scripting","id":"CVE-2015-1866","kev_date_added":null,"published":"2017-09-20"},{"cvss_score":6.1,"headline":"ember-source Cross-site Scripting vulnerability","id":"CVE-2015-7565","kev_date_added":null,"published":"2017-04-13"},{"cvss_score":5.4,"headline":"Ember.js Cross-site Scripting vulnerability","id":"CVE-2014-0013","kev_date_added":null,"published":"2018-02-15"},{"cvss_score":5.4,"headline":"ember-source Cross-site Scripting vulnerability","id":"CVE-2014-0014","kev_date_added":null,"published":"2018-02-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the title attribute in the link-to helper, requiring user interaction to execute.","url":"https://insights.sbomify.com/CVE-2014-0046/"}