# CVE-2014-0056: OpenStack Neutron Improper Authentication vulnerability

> Authenticated users can bypass tenant isolation to attach network ports to arbitrary tenants' routers in OpenStack Neutron.

- **Severity:** Low 2.1 (`AV:N/AC:H/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-0056, GHSA-72p9-6gc7-q93r, PYSEC-2026-851

## What is CVE-2014-0056?

CVE-2014-0056 is a low-severity missing authorization vulnerability in Canonical Ubuntu Linux, published on 8 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The l3-agent in OpenStack Neutron 2012.2 before 2013.2.3 does not check the tenant id when creating ports, which allows remote authenticated users to plug ports into the routers of arbitrary tenants via the device id in a port-create command.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2014-0056?

3 open source packages ship an affected version, including neutron. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neutron` | PyPI | From 2012.2 | 2013.2.3 |
| `neutron` | PyPI | From 2012.2 | 2013.2.3 |
| `neutron` | PyPI | From 2012.2 | 2013.2.3 |

Products: Canonical Ubuntu Linux, Openstack Neutron.

## How do I fix CVE-2014-0056?

Upgrade neutron to 2013.2.3 or later.

## Is CVE-2014-0056 being exploited?

There is no known exploitation of CVE-2014-0056 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0056 and fix it if it is affected.

What it is: CVE-2014-0056 is a low-severity missing authorization vulnerability in Canonical Ubuntu Linux, published on 8 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0056 in the wild and no public exploit code.

Affected packages and fixed versions:
- neutron (PyPI): affected from 2012.2; fixed in 2013.2.3
- neutron (PyPI): affected from 2012.2; fixed in 2013.2.3
- neutron (PyPI): affected from 2012.2; fixed in 2013.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0056/ (Markdown: https://insights.sbomify.com/CVE-2014-0056/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0056
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0056
- OSV: https://osv.dev/vulnerability/CVE-2014-0056

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0056/
Summaries are generated and may contain mistakes; the official description above is the record.
