CVE-2014-0075 Integer Overflow or Wraparound in Apache Tomcat
Remote attackers can cause denial of service in Apache Tomcat via integer overflow in chunked transfer coding headers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-0075?
CVE-2014-0075 is a medium-severity vulnerability in Apache Tomcat, published on 31 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Integer overflow in the parseChunkHeader function in java/org/apache/coyote/http11/filters/ChunkedInputFilter.java in Apache Tomcat before 6.0.40, 7.x before 7.0.53, and 8.x before 8.0.4 allows remote attackers to cause a denial of service (resource consumption) via a malformed chunk size in chunked transfer coding of a request during the streaming of data.
Weakness: CWE-189
Which versions are affected by CVE-2014-0075?
12 open source packages ship an affected version, including org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-coyote. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | All versions | 6.0.40 |
org.apache.tomcat:tomcat Maven | All versions | 6.0.40 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.53 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.53 |
org.apache.tomcat:tomcat Maven | From 8.0.0 | 8.0.4 |
org.apache.tomcat:tomcat Maven | From 8.0.0 | 8.0.4 |
6 more packages
org.apache.tomcat:tomcat-coyote Maven | All versions | 6.0.40 |
org.apache.tomcat:tomcat-coyote Maven | All versions | 6.0.40 |
org.apache.tomcat:tomcat-coyote Maven | From 7.0.0 | 7.0.53 |
org.apache.tomcat:tomcat-coyote Maven | From 7.0.0 | 7.0.53 |
org.apache.tomcat:tomcat-coyote Maven | From 8.0.0 | 8.0.4 |
org.apache.tomcat:tomcat-coyote Maven | From 8.0.0 | 8.0.4 |
Products include Apache Tomcat.
How do I fix CVE-2014-0075?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 6.0.40, 7.0.53 or 8.0.4.
Is CVE-2014-0075 being exploited?
There is no known exploitation of CVE-2014-0075 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-475f-74wp-pqv5, UBUNTU-CVE-2014-0075.