CVE-2014-0080 Array data injection vulnerability in activerecord

Medium 6.8 Published Updated

Remote attackers can execute SQL commands via backslash characters in array columns when using PostgreSQL with Active Record.

Exploited in the wild
Not known
Login needed
Not stated
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-0080?

CVE-2014-0080 is a medium-severity SQL injection vulnerability in Rubyonrails Rails, published on 20 Feb 2014. It can be exploited over the network, with no action from the victim.

Official description

SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/cast.rb in Active Record in Ruby on Rails 4.0.x before 4.0.3, and 4.1.0.beta1, when PostgreSQL is used, allows remote attackers to execute "add data" SQL commands via vectors involving \ (backslash) characters that are not properly handled in operations on array columns.

Weakness: CWE-89

Which versions are affected by CVE-2014-0080?

4 open source packages ship an affected version, including activerecord. It affects 1 product.

PackageAffectedFixed in
activerecord RubyGemsFrom 4.0.04.0.3
activerecord RubyGemsFrom 4.0.04.0.3
activerecord RubyGemsFrom 4.1.0.beta14.1.0.beta2
activerecord RubyGemsFrom 4.1.0.beta14.1.0.beta2

Products include Rubyonrails Rails.

How do I fix CVE-2014-0080?

Upgrade activerecord to a fixed version for your release line: 4.0.3 or 4.1.0.beta2.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2014-0080 being exploited?

There is no known exploitation of CVE-2014-0080 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as GHSA-hqf9-rc9j-5fmj.

Is CVE-2014-0080 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free