# CVE-2014-0080: Array data injection vulnerability in activerecord

> Remote attackers can execute SQL commands via backslash characters in array columns when using PostgreSQL with Active Record.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-hqf9-rc9j-5fmj

## What is CVE-2014-0080?

CVE-2014-0080 is a medium-severity SQL injection vulnerability in Rubyonrails Rails, published on 20 Feb 2014. It can be exploited over the network, with no action from the victim.

### Official description

SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/cast.rb in Active Record in Ruby on Rails 4.0.x before 4.0.3, and 4.1.0.beta1, when PostgreSQL is used, allows remote attackers to execute "add data" SQL commands via vectors involving \ (backslash) characters that are not properly handled in operations on array columns.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2014-0080?

4 open source packages ship an affected version, including activerecord. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activerecord` | RubyGems | From 4.0.0 | 4.0.3 |
| `activerecord` | RubyGems | From 4.0.0 | 4.0.3 |
| `activerecord` | RubyGems | From 4.1.0.beta1 | 4.1.0.beta2 |
| `activerecord` | RubyGems | From 4.1.0.beta1 | 4.1.0.beta2 |

Products: Rubyonrails Rails.

## How do I fix CVE-2014-0080?

Upgrade activerecord to a fixed version for your release line: 4.0.3 or 4.1.0.beta2.

## Is CVE-2014-0080 being exploited?

There is no known exploitation of CVE-2014-0080 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0080 and fix it if it is affected.

What it is: CVE-2014-0080 is a medium-severity SQL injection vulnerability in Rubyonrails Rails, published on 20 Feb 2014. It can be exploited over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0080 in the wild and no public exploit code.

Affected packages and fixed versions:
- activerecord (RubyGems): affected from 4.0.0; fixed in 4.0.3
- activerecord (RubyGems): affected from 4.0.0; fixed in 4.0.3
- activerecord (RubyGems): affected from 4.1.0.beta1; fixed in 4.1.0.beta2
- activerecord (RubyGems): affected from 4.1.0.beta1; fixed in 4.1.0.beta2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0080/ (Markdown: https://insights.sbomify.com/CVE-2014-0080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0080
- OSV: https://osv.dev/vulnerability/CVE-2014-0080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0080/
Summaries are generated and may contain mistakes; the official description above is the record.
