CVE-2014-0081 Rails vulnerable to Cross-site Scripting
Remote attackers can inject arbitrary web script or HTML via number helper parameters in Ruby on Rails, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-0081?
CVE-2014-0081 is a medium-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 20 Feb 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in actionview/lib/action_view/helpers/number_helper.rb in Ruby on Rails before 3.2.17, 4.0.x before 4.0.3, and 4.1.x before 4.1.0.beta2 allow remote attackers to inject arbitrary web script or HTML via the (1) format, (2) negative_format, or (3) units parameter to the (a) number_to_currency, (b) number_to_percentage, or (c) number_to_human helper.
Weakness: CWE-79
Which versions are affected by CVE-2014-0081?
8 open source packages ship an affected version, including actionpack and rails. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
actionpack RubyGems | From 3.0.0 | 3.2.17 |
actionpack RubyGems | From 3.0.0 | 3.2.17 |
actionpack RubyGems | From 4.0.0 | 4.0.3 |
actionpack RubyGems | From 4.0.0 | 4.0.3 |
rails RubyGems | From 3.0.0 | 3.2.17 |
rails RubyGems | From 3.0.0 | 3.2.17 |
2 more packages
rails RubyGems | From 4.0.0 | 4.0.3 |
rails RubyGems | From 4.0.0 | 4.0.3 |
Products include Opensuse Opensuse, Opensuse Project Opensuse, Redhat Cloudforms, Redhat Enterprise Linux, Rubyonrails Rails, Rubyonrails Ruby on Rails.
How do I fix CVE-2014-0081?
Upgrade actionpack to a fixed version for your release line: 3.2.17 or 4.0.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-0081 being exploited?
There is no known exploitation of CVE-2014-0081 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Opensuse
Sources
Also known as DEBIAN-CVE-2014-0081, GHSA-m46p-ggm5-5j83.