{"answers":{"affected":"8 open source packages ship an affected version, including actionpack and rails. It affects 6 products.","exploited":"There is no known exploitation of CVE-2014-0081 in the wild and no public exploit code.","fix":"Upgrade actionpack to a fixed version for your release line: 3.2.17 or 4.0.3.","what":"CVE-2014-0081 is a medium-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 20 Feb 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-0081 and fix it if it is affected.\n\nWhat it is: CVE-2014-0081 is a medium-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 20 Feb 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-0081 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.17\n- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.17\n- actionpack (RubyGems): affected from 4.0.0; fixed in 4.0.3\n- actionpack (RubyGems): affected from 4.0.0; fixed in 4.0.3\n- rails (RubyGems): affected from 3.0.0; fixed in 3.2.17\n- rails (RubyGems): affected from 3.0.0; fixed in 3.2.17\n- rails (RubyGems): affected from 4.0.0; fixed in 4.0.3\n- rails (RubyGems): affected from 4.0.0; fixed in 4.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0081/ (Markdown: https://insights.sbomify.com/CVE-2014-0081/index.md)","id":"CVE-2014-0081","markdown":"https://insights.sbomify.com/CVE-2014-0081/index.md","name":"CVE-2014-0081","record":{"aliases":["DEBIAN-CVE-2014-0081","GHSA-m46p-ggm5-5j83"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via number helper parameters in Ruby on Rails, potentially leading to code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"opensuse","vendor":"opensuse"},{"product":"opensuse","vendor":"opensuse_project"},{"product":"cloudforms","vendor":"redhat"},{"product":"enterprise_linux","vendor":"redhat"},{"product":"rails","vendor":"rubyonrails"},{"product":"ruby_on_rails","vendor":"rubyonrails"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in actionview/lib/action_view/helpers/number_helper.rb in Ruby on Rails before 3.2.17, 4.0.x before 4.0.3, and 4.1.x before 4.1.0.beta2 allow remote attackers to inject arbitrary web script or HTML via the (1) format, (2) negative_format, or (3) units parameter to the (a) number_to_currency, (b) number_to_percentage, or (c) number_to_human helper.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Rails vulnerable to Cross-site Scripting","id":"CVE-2014-0081","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"opensuse:opensuse","products":["opensuse:opensuse","redhat:enterprise_linux","rubyonrails:rails"],"type":"xss","year":"2014"},"n_packages":8,"n_references":8,"next":{"headline":"actionpack Improper Input Validation vulnerability","id":"CVE-2014-0082"},"packages":[{"ecosystem":"RubyGems","fixed":["3.2.17"],"introduced":["3.0.0"],"last_affected":[],"package":"actionpack","purl":null,"source":"GHSA-m46p-ggm5-5j83"},{"ecosystem":"RubyGems","fixed":["3.2.17"],"introduced":["3.0.0"],"last_affected":[],"package":"actionpack","purl":"pkg:gem/actionpack","source":"GHSA-m46p-ggm5-5j83"},{"ecosystem":"RubyGems","fixed":["4.0.3"],"introduced":["4.0.0"],"last_affected":[],"package":"actionpack","purl":null,"source":"GHSA-m46p-ggm5-5j83"},{"ecosystem":"RubyGems","fixed":["4.0.3"],"introduced":["4.0.0"],"last_affected":[],"package":"actionpack","purl":"pkg:gem/actionpack","source":"GHSA-m46p-ggm5-5j83"},{"ecosystem":"RubyGems","fixed":["3.2.17"],"introduced":["3.0.0"],"last_affected":[],"package":"rails","purl":null,"source":"GHSA-m46p-ggm5-5j83"},{"ecosystem":"RubyGems","fixed":["3.2.17"],"introduced":["3.0.0"],"last_affected":[],"package":"rails","purl":"pkg:gem/rails","source":"GHSA-m46p-ggm5-5j83"},{"ecosystem":"RubyGems","fixed":["4.0.3"],"introduced":["4.0.0"],"last_affected":[],"package":"rails","purl":null,"source":"GHSA-m46p-ggm5-5j83"},{"ecosystem":"RubyGems","fixed":["4.0.3"],"introduced":["4.0.0"],"last_affected":[],"package":"rails","purl":"pkg:gem/rails","source":"GHSA-m46p-ggm5-5j83"}],"prev":{"headline":"Array data injection vulnerability in activerecord","id":"CVE-2014-0080"},"products":["n/a"],"published":"2014-02-20","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-5957","kev_date_added":null,"published":"2015-09-28"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0491","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2008-2388","kev_date_added":null,"published":"2008-06-06"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2010-1866","kev_date_added":null,"published":"2010-05-07"},{"cvss_score":9.3,"headline":"Other in n/a","id":"CVE-2015-0492","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2014-0158","kev_date_added":null,"published":"2018-04-10"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2016-4343","kev_date_added":null,"published":"2016-05-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via number helper parameters in Ruby on Rails, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2014-0081/"}