# CVE-2014-0081: Rails vulnerable to Cross-site Scripting

> Remote attackers can inject arbitrary web script or HTML via number helper parameters in Ruby on Rails, potentially leading to code execution.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-0081, GHSA-m46p-ggm5-5j83

## What is CVE-2014-0081?

CVE-2014-0081 is a medium-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 20 Feb 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in actionview/lib/action_view/helpers/number_helper.rb in Ruby on Rails before 3.2.17, 4.0.x before 4.0.3, and 4.1.x before 4.1.0.beta2 allow remote attackers to inject arbitrary web script or HTML via the (1) format, (2) negative_format, or (3) units parameter to the (a) number_to_currency, (b) number_to_percentage, or (c) number_to_human helper.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-0081?

8 open source packages ship an affected version, including actionpack and rails. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 3.0.0 | 3.2.17 |
| `actionpack` | RubyGems | From 3.0.0 | 3.2.17 |
| `actionpack` | RubyGems | From 4.0.0 | 4.0.3 |
| `actionpack` | RubyGems | From 4.0.0 | 4.0.3 |
| `rails` | RubyGems | From 3.0.0 | 3.2.17 |
| `rails` | RubyGems | From 3.0.0 | 3.2.17 |
| `rails` | RubyGems | From 4.0.0 | 4.0.3 |
| `rails` | RubyGems | From 4.0.0 | 4.0.3 |

Products: Opensuse Opensuse, Opensuse Project Opensuse, Redhat Cloudforms, Redhat Enterprise Linux, Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2014-0081?

Upgrade actionpack to a fixed version for your release line: 3.2.17 or 4.0.3.

## Is CVE-2014-0081 being exploited?

There is no known exploitation of CVE-2014-0081 in the wild and no public exploit code.

## Other vulnerabilities in Opensuse Opensuse

- [CVE-2015-5957](https://insights.sbomify.com/CVE-2015-5957/): Memory corruption in n/a (critical 10.0)
- [CVE-2015-0491](https://insights.sbomify.com/CVE-2015-0491/): Memory corruption in n/a (critical 10.0)
- [CVE-2008-2388](https://insights.sbomify.com/CVE-2008-2388/): Integer overflow in n/a (critical 10.0)
- [CVE-2010-1866](https://insights.sbomify.com/CVE-2010-1866/): Integer overflow in n/a (critical 9.8)
- [CVE-2015-0492](https://insights.sbomify.com/CVE-2015-0492/): Other in n/a (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0081 and fix it if it is affected.

What it is: CVE-2014-0081 is a medium-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 20 Feb 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-0081 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.17
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.17
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.0.3
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.0.3
- rails (RubyGems): affected from 3.0.0; fixed in 3.2.17
- rails (RubyGems): affected from 3.0.0; fixed in 3.2.17
- rails (RubyGems): affected from 4.0.0; fixed in 4.0.3
- rails (RubyGems): affected from 4.0.0; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0081/ (Markdown: https://insights.sbomify.com/CVE-2014-0081/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0081
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0081
- OSV: https://osv.dev/vulnerability/CVE-2014-0081

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0081/
Summaries are generated and may contain mistakes; the official description above is the record.
