{"answers":{"affected":"2 open source packages ship an affected version, including net-ldap. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-0083 in the wild and no public exploit code.","fix":"Upgrade net-ldap to 0.16.2 or later.","what":"CVE-2014-0083 is a medium-severity vulnerability in Debian Debian Linux, published on 21 Nov 2019. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0083 and fix it if it is affected.\n\nWhat it is: CVE-2014-0083 is a medium-severity vulnerability in Debian Debian Linux, published on 21 Nov 2019. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-0083 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- net-ldap (RubyGems): affected all versions; fixed in 0.16.2\n- net-ldap (RubyGems): affected all versions; fixed in 0.16.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0083/ (Markdown: https://insights.sbomify.com/CVE-2014-0083/index.md)","id":"CVE-2014-0083","markdown":"https://insights.sbomify.com/CVE-2014-0083/index.md","name":"CVE-2014-0083","record":{"aliases":["GHSA-qwgm-mxm4-3q2c","UBUNTU-CVE-2014-0083"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby LDAP library","requires_auth":"low_privilege","summary":"The Ruby net-ldap gem uses a weak salt for SSHA password generation, potentially allowing attackers to recover passwords.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"net-ldap","vendor":"net-ldap_project"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-916","name":"Use of Password Hash With Insufficient Computational Effort"}],"description":"The Ruby net-ldap gem before 0.11 uses a weak salt when generating SSHA passwords.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"net-ldap has weak salt when generating passwords","id":"CVE-2014-0083","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"weak_cryptography","year":"2014"},"n_packages":2,"n_references":4,"next":{"headline":"openshift-origin-node Improper Input Validation vulnerability","id":"CVE-2014-0084"},"packages":[{"ecosystem":"RubyGems","fixed":["0.16.2"],"introduced":["0"],"last_affected":[],"package":"net-ldap","purl":null,"source":"GHSA-qwgm-mxm4-3q2c"},{"ecosystem":"RubyGems","fixed":["0.16.2"],"introduced":["0"],"last_affected":[],"package":"net-ldap","purl":"pkg:gem/net-ldap","source":"GHSA-qwgm-mxm4-3q2c"}],"prev":{"headline":"actionpack Improper Input Validation vulnerability","id":"CVE-2014-0082"},"products":["ruby-net-ldap"],"published":"2019-11-21","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["ruby-net-ldap"]},"summary":"The Ruby net-ldap gem uses a weak salt for SSHA password generation, potentially allowing attackers to recover passwords.","url":"https://insights.sbomify.com/CVE-2014-0083/"}