{"answers":{"affected":"2 open source packages ship an affected version, including org.jboss.fuse:jboss-fuse. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-0085 in the wild and no public exploit code.","fix":"Upgrade org.jboss.fuse:jboss-fuse to 6.1.0 or later.","what":"CVE-2014-0085 is a low-severity vulnerability in n/a, published on 17 Apr 2014. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0085 and fix it if it is affected.\n\nWhat it is: CVE-2014-0085 is a low-severity vulnerability in n/a, published on 17 Apr 2014. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-0085 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jboss.fuse:jboss-fuse (Maven): affected all versions; fixed in 6.1.0\n- org.jboss.fuse:jboss-fuse (Maven): affected all versions; fixed in 6.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0085/ (Markdown: https://insights.sbomify.com/CVE-2014-0085/index.md)","id":"CVE-2014-0085","markdown":"https://insights.sbomify.com/CVE-2014-0085/index.md","name":"CVE-2014-0085","record":{"aliases":["GHSA-h259-3rjg-5qp3","UBUNTU-CVE-2014-0085"],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"JBoss Fuse","requires_auth":"low_privilege","summary":"Local attackers can read cleartext admin passwords from logs because JBoss Fuse does not enable encrypted passwords by default.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jboss_a-mq","vendor":"redhat"},{"product":"jboss_fuse","vendor":"redhat"}],"cvss":{"score":2.1,"severity":"low","source":"nvd","vector":"AV:L/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-255","name":null}],"description":"JBoss Fuse did not enable encrypted passwords by default in its usage of Apache Zookeeper. This permitted sensitive information disclosure via logging to local users. Note: this description has been updated; previous text mistakenly identified the source of the flaw as Zookeeper. Previous text: Apache Zookeeper logs cleartext admin passwords, which allows local users to obtain sensitive information by reading the log.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in JBoss Fuse","id":"CVE-2014-0085","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2014"},"n_packages":2,"n_references":1,"next":{"headline":"JBoss RichFaces Improper Input Validation vulnerability","id":"CVE-2014-0086"},"packages":[{"ecosystem":"Maven","fixed":["6.1.0"],"introduced":["0"],"last_affected":[],"package":"org.jboss.fuse:jboss-fuse","purl":null,"source":"GHSA-h259-3rjg-5qp3"},{"ecosystem":"Maven","fixed":["6.1.0"],"introduced":["0"],"last_affected":[],"package":"org.jboss.fuse:jboss-fuse","purl":"pkg:maven/org.jboss.fuse/jboss-fuse","source":"GHSA-h259-3rjg-5qp3"}],"prev":{"headline":"openshift-origin-node Improper Input Validation vulnerability","id":"CVE-2014-0084"},"products":["n/a"],"published":"2014-04-17","related":[{"cvss_score":7.2,"headline":"Deserialization in Karaf","id":"CVE-2016-8648","kev_date_added":null,"published":"2018-08-01"},{"cvss_score":5.6,"headline":"XML external entity in Red Hat AMQ","id":"CVE-2020-14379","kev_date_added":null,"published":"2022-08-16"},{"cvss_score":5.5,"headline":"Operator: passwords defined in secrets shown in statefulset yaml","id":"CVE-2023-4066","kev_date_added":null,"published":"2023-09-27"},{"cvss_score":5.5,"headline":"Operator: plaintext password in operator log","id":"CVE-2023-4065","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2015-5181","kev_date_added":null,"published":"2017-09-25"},{"cvss_score":5.3,"headline":"Deserialization in Fuse","id":"CVE-2016-8653","kev_date_added":null,"published":"2018-08-01"},{"cvss_score":4.4,"headline":"Information disclosure in broker","id":"CVE-2021-3425","kev_date_added":null,"published":"2021-06-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can read cleartext admin passwords from logs because JBoss Fuse does not enable encrypted passwords by default.","url":"https://insights.sbomify.com/CVE-2014-0085/"}