# CVE-2014-0085: Exposure of Sensitive Information to an Unauthorized Actor in JBoss Fuse

> Local attackers can read cleartext admin passwords from logs because JBoss Fuse does not enable encrypted passwords by default.

- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-h259-3rjg-5qp3, UBUNTU-CVE-2014-0085

## What is CVE-2014-0085?

CVE-2014-0085 is a low-severity vulnerability in n/a, published on 17 Apr 2014. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

JBoss Fuse did not enable encrypted passwords by default in its usage of Apache Zookeeper. This permitted sensitive information disclosure via logging to local users. Note: this description has been updated; previous text mistakenly identified the source of the flaw as Zookeeper. Previous text: Apache Zookeeper logs cleartext admin passwords, which allows local users to obtain sensitive information by reading the log.

Weakness: CWE-255

## Which versions are affected by CVE-2014-0085?

2 open source packages ship an affected version, including org.jboss.fuse:jboss-fuse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jboss.fuse:jboss-fuse` | Maven | All versions | 6.1.0 |
| `org.jboss.fuse:jboss-fuse` | Maven | All versions | 6.1.0 |

Products: Redhat Jboss A-Mq, Redhat Jboss Fuse.

## How do I fix CVE-2014-0085?

Upgrade org.jboss.fuse:jboss-fuse to 6.1.0 or later.

## Is CVE-2014-0085 being exploited?

There is no known exploitation of CVE-2014-0085 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-8648](https://insights.sbomify.com/CVE-2016-8648/): Deserialization in Karaf (high 7.2)
- [CVE-2020-14379](https://insights.sbomify.com/CVE-2020-14379/): XML external entity in Red Hat AMQ (medium 5.6)
- [CVE-2023-4066](https://insights.sbomify.com/CVE-2023-4066/): Operator: passwords defined in secrets shown in statefulset yaml (medium 5.5)
- [CVE-2023-4065](https://insights.sbomify.com/CVE-2023-4065/): Operator: plaintext password in operator log (medium 5.5)
- [CVE-2015-5181](https://insights.sbomify.com/CVE-2015-5181/): Cross-site scripting in n/a (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0085 and fix it if it is affected.

What it is: CVE-2014-0085 is a low-severity vulnerability in n/a, published on 17 Apr 2014. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0085 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jboss.fuse:jboss-fuse (Maven): affected all versions; fixed in 6.1.0
- org.jboss.fuse:jboss-fuse (Maven): affected all versions; fixed in 6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0085/ (Markdown: https://insights.sbomify.com/CVE-2014-0085/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0085
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0085
- OSV: https://osv.dev/vulnerability/CVE-2014-0085

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0085/
Summaries are generated and may contain mistakes; the official description above is the record.
