# CVE-2014-0086: JBoss RichFaces Improper Input Validation vulnerability

> Remote attackers can cause denial of service via memory exhaustion by sending malformed push requests to JBoss RichFaces applications.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-xfxv-f945-4qv6

## What is CVE-2014-0086?

CVE-2014-0086 is a medium-severity denial of service vulnerability in n/a, published on 28 Mar 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The doFilter function in webapp/PushHandlerFilter.java in JBoss RichFaces 4.3.4, 4.3.5, and 5.x allows remote attackers to cause a denial of service (memory consumption and out-of-memory error) via a large number of malformed atmosphere push requests.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-0086?

4 open source packages ship an affected version, including org.richfaces:richfaces. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.richfaces:richfaces` | Maven | From 4.3.4 to 4.3.5 | None |
| `org.richfaces:richfaces` | Maven | From 4.3.4 to 4.3.5 | None |
| `org.richfaces:richfaces` | Maven | From 5.0.0.Alpha1 | 5.0.0.Alpha3 |
| `org.richfaces:richfaces` | Maven | From 5.0.0.Alpha1 | 5.0.0.Alpha3 |

Products: Redhat Jboss Web Framework Kit, Redhat Richfaces.

## How do I fix CVE-2014-0086?

Upgrade org.richfaces:richfaces to 5.0.0.Alpha3 or later.

## Is CVE-2014-0086 being exploited?

There is no known exploitation of CVE-2014-0086 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-0149](https://insights.sbomify.com/CVE-2014-0149/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0086 and fix it if it is affected.

What it is: CVE-2014-0086 is a medium-severity denial of service vulnerability in n/a, published on 28 Mar 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0086 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.richfaces:richfaces (Maven): affected from 4.3.4 up to 4.3.5; no fix listed
- org.richfaces:richfaces (Maven): affected from 4.3.4 up to 4.3.5; no fix listed
- org.richfaces:richfaces (Maven): affected from 5.0.0.Alpha1; fixed in 5.0.0.Alpha3
- org.richfaces:richfaces (Maven): affected from 5.0.0.Alpha1; fixed in 5.0.0.Alpha3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0086/ (Markdown: https://insights.sbomify.com/CVE-2014-0086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0086
- OSV: https://osv.dev/vulnerability/CVE-2014-0086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0086/
Summaries are generated and may contain mistakes; the official description above is the record.
