{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.struts.xwork:xwork-core and org.apache.struts:struts2-core. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-0094 exists.","fix":"Upgrade org.apache.struts.xwork:xwork-core to 2.3.16.2 or later.","what":"CVE-2014-0094 is a medium-severity code injection vulnerability in Apache Struts, published on 10 Mar 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0094 and fix it if it is affected.\n\nWhat it is: CVE-2014-0094 is a medium-severity code injection vulnerability in Apache Struts, published on 10 Mar 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-0094 exists.\n\nAffected packages and fixed versions:\n- org.apache.struts.xwork:xwork-core (Maven): affected from 2.0.0; fixed in 2.3.16.2\n- org.apache.struts.xwork:xwork-core (Maven): affected from 2.0.0; fixed in 2.3.16.2\n- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.16.2\n- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.16.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0094/ (Markdown: https://insights.sbomify.com/CVE-2014-0094/index.md)","id":"CVE-2014-0094","markdown":"https://insights.sbomify.com/CVE-2014-0094/index.md","name":"CVE-2014-0094","record":{"aliases":["GHSA-vrwc-qjmw-5rjm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web framework","requires_auth":"none","summary":"Remote attackers can manipulate the ClassLoader to execute arbitrary code in applications using Apache Struts.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"struts","vendor":"apache"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"The ParametersInterceptor in Apache Struts before 2.3.16.2 allows remote attackers to \"manipulate\" the ClassLoader via the class parameter, which is passed to the getClass method.","ecosystems":["Maven"],"exploits":{"exploitdb":2,"first_seen":"2014-03-06","github_poc":2,"max_poc_stars":1,"metasploit":1,"nuclei":0,"refs":[{"date":"2014-04-27T11:31:59Z","kind":"github_poc","ref":"https://github.com/HasegawaTadamitsu/CVE-2014-0094-test-program-for-struts1","stars":1,"title":"CVE-2014-0094 test program for struts1"},{"date":"2023-06-14T02:06:58Z","kind":"github_poc","ref":"https://github.com/y0d3n/CVE-2014-0094","stars":1,"title":null},{"date":"2014-03-06","kind":"exploitdb","ref":"41690","stars":null,"title":"Apache Struts \u003c 1.3.10 / \u003c 2.3.16.2 - ClassLoader Manipulation Remote Code Execution (Metasploit)"},{"date":"2014-03-06","kind":"metasploit","ref":"exploit/multi/http/struts_code_exec_classloader","stars":null,"title":"Apache Struts ClassLoader Manipulation Remote Code Execution"},{"date":"2014-05-02","kind":"exploitdb","ref":"33142","stars":null,"title":"Apache Struts - ClassLoader Manipulation Remote Code Execution (Metasploit)"}],"tier":"weaponised"},"has_fix":true,"headline":"ClassLoader manipulation in Apache Struts","id":"CVE-2014-0094","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:struts","products":["apache:struts"],"type":"code_injection","year":"2014"},"n_packages":4,"n_references":15,"next":{"headline":"Denial of service in Apache Tomcat","id":"CVE-2014-0095"},"packages":[{"ecosystem":"Maven","fixed":["2.3.16.2"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.struts.xwork:xwork-core","purl":null,"source":"GHSA-vrwc-qjmw-5rjm"},{"ecosystem":"Maven","fixed":["2.3.16.2"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.struts.xwork:xwork-core","purl":"pkg:maven/org.apache.struts.xwork/xwork-core","source":"GHSA-vrwc-qjmw-5rjm"},{"ecosystem":"Maven","fixed":["2.3.16.2"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":null,"source":"GHSA-vrwc-qjmw-5rjm"},{"ecosystem":"Maven","fixed":["2.3.16.2"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":"pkg:maven/org.apache.struts/struts2-core","source":"GHSA-vrwc-qjmw-5rjm"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2014-0093"},"products":["n/a"],"published":"2014-03-10","related":[{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2020-17530","kev_date_added":"2021-11-03","published":"2020-12-11"},{"cvss_score":9.8,"headline":"Apache Struts 1 Improper Input Validation","id":"CVE-2017-9791","kev_date_added":"2022-02-10","published":"2017-07-10"},{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2017-5638","kev_date_added":"2021-11-03","published":"2017-03-11"},{"cvss_score":9.8,"headline":"Apache Struts 2 Improper Input Validation","id":"CVE-2012-0391","kev_date_added":"2022-01-21","published":"2012-01-08"},{"cvss_score":8.1,"headline":"Apache Struts Remote Code Execution","id":"CVE-2018-11776","kev_date_added":"2021-11-03","published":"2018-08-22"},{"cvss_score":8.1,"headline":"Apache Struts Deserialization of Untrusted Data","id":"CVE-2017-9805","kev_date_added":"2021-11-03","published":"2017-09-15"},{"cvss_score":8.1,"headline":"Apache Struts Command Injection","id":"CVE-2016-3081","kev_date_added":"2026-10-08","published":"2016-04-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can manipulate the ClassLoader to execute arbitrary code in applications using Apache Struts.","url":"https://insights.sbomify.com/CVE-2014-0094/"}