CVE-2014-0096 Improper Input Validation in Apache Tomcat
Remote attackers can bypass security restrictions and read arbitrary files via XXE in Tomcat's default servlet, requiring a crafted web application.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-0096?
CVE-2014-0096 is a medium-severity vulnerability in Apache Tomcat, published on 31 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
java/org/apache/catalina/servlets/DefaultServlet.java in the default servlet in Apache Tomcat before 6.0.40, 7.x before 7.0.53, and 8.x before 8.0.4 does not properly restrict XSLT stylesheets, which allows remote attackers to bypass security-manager restrictions and read arbitrary files via a crafted web application that provides an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
Weakness: CWE-264
Which versions are affected by CVE-2014-0096?
12 open source packages ship an affected version, including org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-catalina. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | All versions | 6.0.40 |
org.apache.tomcat:tomcat Maven | All versions | 6.0.40 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.54 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.54 |
org.apache.tomcat:tomcat Maven | From 8.0.0 | 8.0.6 |
org.apache.tomcat:tomcat Maven | From 8.0.0 | 8.0.6 |
6 more packages
org.apache.tomcat:tomcat-catalina Maven | All versions | 6.0.40 |
org.apache.tomcat:tomcat-catalina Maven | All versions | 6.0.40 |
org.apache.tomcat:tomcat-catalina Maven | From 7.0.0 | 7.0.54 |
org.apache.tomcat:tomcat-catalina Maven | From 7.0.0 | 7.0.54 |
org.apache.tomcat:tomcat-catalina Maven | From 8.0.0 | 8.0.6 |
org.apache.tomcat:tomcat-catalina Maven | From 8.0.0 | 8.0.6 |
Products include Apache Tomcat.
How do I fix CVE-2014-0096?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 6.0.40, 7.0.54 or 8.0.6.
Is CVE-2014-0096 being exploited?
There is no known exploitation of CVE-2014-0096 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-qprx-q2r7-3rx6, UBUNTU-CVE-2014-0096.