# CVE-2014-0096: Improper Input Validation in Apache Tomcat

> Remote attackers can bypass security restrictions and read arbitrary files via XXE in Tomcat's default servlet, requiring a crafted web application.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2014
- **Updated:** 14 Oct 2026
- **Also known as:** GHSA-qprx-q2r7-3rx6, UBUNTU-CVE-2014-0096

## What is CVE-2014-0096?

CVE-2014-0096 is a medium-severity vulnerability in Apache Tomcat, published on 31 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

java/org/apache/catalina/servlets/DefaultServlet.java in the default servlet in Apache Tomcat before 6.0.40, 7.x before 7.0.53, and 8.x before 8.0.4 does not properly restrict XSLT stylesheets, which allows remote attackers to bypass security-manager restrictions and read arbitrary files via a crafted web application that provides an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Weakness: CWE-264

## Which versions are affected by CVE-2014-0096?

12 open source packages ship an affected version, including org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-catalina. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | All versions | 6.0.40 |
| `org.apache.tomcat:tomcat` | Maven | All versions | 6.0.40 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.54 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.54 |
| `org.apache.tomcat:tomcat` | Maven | From 8.0.0 | 8.0.6 |
| `org.apache.tomcat:tomcat` | Maven | From 8.0.0 | 8.0.6 |
| `org.apache.tomcat:tomcat-catalina` | Maven | All versions | 6.0.40 |
| `org.apache.tomcat:tomcat-catalina` | Maven | All versions | 6.0.40 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 7.0.0 | 7.0.54 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 7.0.0 | 7.0.54 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.0.0 | 8.0.6 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.0.0 | 8.0.6 |

Products: Apache Tomcat.

## How do I fix CVE-2014-0096?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 6.0.40, 7.0.54 or 8.0.6.

## Is CVE-2014-0096 being exploited?

There is no known exploitation of CVE-2014-0096 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0096 and fix it if it is affected.

What it is: CVE-2014-0096 is a medium-severity vulnerability in Apache Tomcat, published on 31 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0096 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected all versions; fixed in 6.0.40
- org.apache.tomcat:tomcat (Maven): affected all versions; fixed in 6.0.40
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.54
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.54
- org.apache.tomcat:tomcat (Maven): affected from 8.0.0; fixed in 8.0.6
- org.apache.tomcat:tomcat (Maven): affected from 8.0.0; fixed in 8.0.6
- org.apache.tomcat:tomcat-catalina (Maven): affected all versions; fixed in 6.0.40
- org.apache.tomcat:tomcat-catalina (Maven): affected all versions; fixed in 6.0.40
- org.apache.tomcat:tomcat-catalina (Maven): affected from 7.0.0; fixed in 7.0.54
- org.apache.tomcat:tomcat-catalina (Maven): affected from 7.0.0; fixed in 7.0.54
- org.apache.tomcat:tomcat-catalina (Maven): affected from 8.0.0; fixed in 8.0.6
- org.apache.tomcat:tomcat-catalina (Maven): affected from 8.0.0; fixed in 8.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0096/ (Markdown: https://insights.sbomify.com/CVE-2014-0096/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0096
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0096
- OSV: https://osv.dev/vulnerability/CVE-2014-0096

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0096/
Summaries are generated and may contain mistakes; the official description above is the record.
