# CVE-2014-0105: python-keystoneclient vulnerable to context confusion in Keystone auth_token middleware

> Remote authenticated users can gain privileges via memcache token retrieval flaws in the OpenStack Keystone Python client library.

- **Severity:** Medium 6.0 (`AV:N/AC:M/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-0105, GHSA-gwvq-rgqf-993f, PYSEC-2014-70, RHSA-2014:0382, RHSA-2014:0409, RHSA-2014:0442

## What is CVE-2014-0105?

CVE-2014-0105 is a medium-severity vulnerability in n/a, published on 15 Apr 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The auth_token middleware in the OpenStack Python client library for Keystone (aka python-keystoneclient) before 0.7.0 does not properly retrieve user tokens from memcache, which allows remote authenticated users to gain privileges in opportunistic circumstances via a large number of requests, related to an "interaction between eventlet and python-memcached."

Weakness: CWE-255

## Which versions are affected by CVE-2014-0105?

3 open source packages ship an affected version, including python-keystoneclient. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-keystoneclient` | PyPI | All versions | 0.7.0 |
| `python-keystoneclient` | PyPI | All versions | 0.7.0 |
| `python-keystoneclient` | PyPI | All versions | 0.7.0 |
| `python-keystoneclient` | Red Hat:openstack:3::el6 | All versions | 1:0.2.3-8.el6ost |
| `python-keystoneclient-doc` | Red Hat:openstack:3::el6 | All versions | 1:0.2.3-8.el6ost |
| `python-keystoneclient` | Red Hat:openstack:4::el6 | All versions | 1:0.7.1-2.el6ost |
| `python-keystoneclient-doc` | Red Hat:openstack:4::el6 | All versions | 1:0.7.1-2.el6ost |
| `python-six` | Red Hat:openstack:4::el6 | All versions | 0:1.5.2-1.el6 |
| `python-keystoneclient` | Red Hat:storage:2.1:server:el6 | All versions | 1:0.7.1-2.el6ost |
| `python-keystoneclient-doc` | Red Hat:storage:2.1:server:el6 | All versions | 1:0.7.1-2.el6ost |
| `python-six` | Red Hat:storage:2.1:server:el6 | All versions | 0:1.5.2-1.el6 |

Products: Openstack Python-Keystoneclient.

## How do I fix CVE-2014-0105?

Upgrade python-keystoneclient to 0.7.0 or later.

## Is CVE-2014-0105 being exploited?

There is no known exploitation of CVE-2014-0105 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-2104](https://insights.sbomify.com/CVE-2013-2104/): python-keystoneclient missing expiration check in PKI token validation (medium 5.5)
- [CVE-2013-2013](https://insights.sbomify.com/CVE-2013-2013/): python-keystoneclient unsecure user password update (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0105 and fix it if it is affected.

What it is: CVE-2014-0105 is a medium-severity vulnerability in n/a, published on 15 Apr 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0105 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-keystoneclient (PyPI): affected all versions; fixed in 0.7.0
- python-keystoneclient (PyPI): affected all versions; fixed in 0.7.0
- python-keystoneclient (PyPI): affected all versions; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0105/ (Markdown: https://insights.sbomify.com/CVE-2014-0105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0105
- OSV: https://osv.dev/vulnerability/CVE-2014-0105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0105/
Summaries are generated and may contain mistakes; the official description above is the record.
