CVE-2014-0110 Uncontrolled Resource Consumption in Apache CXF

Medium 4.3 Published Updated

Remote attackers can cause denial of service by consuming disk space via large invalid SOAP messages in Apache CXF.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-0110?

CVE-2014-0110 is a medium-severity denial of service vulnerability in Apache Cxf, published on 8 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache CXF before 2.6.14 and 2.7.x before 2.7.11 allows remote attackers to cause a denial of service (/tmp disk consumption) via a large invalid SOAP message.

Weakness: CWE-399

Which versions are affected by CVE-2014-0110?

4 open source packages ship an affected version, including org.apache.cxf:cxf-core. It affects 1 product.

PackageAffectedFixed in
org.apache.cxf:cxf-core MavenAll versions2.6.14
org.apache.cxf:cxf-core MavenAll versions2.6.14
org.apache.cxf:cxf-core MavenFrom 2.7.02.7.11
org.apache.cxf:cxf-core MavenFrom 2.7.02.7.11

Products include Apache Cxf.

How do I fix CVE-2014-0110?

Upgrade org.apache.cxf:cxf-core to a fixed version for your release line: 2.6.14 or 2.7.11.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2014-0110 being exploited?

There is no known exploitation of CVE-2014-0110 in the wild and no public exploit code.

All Apache Cxf vulnerabilities

Sources

Also known as GHSA-5xf9-3v63-ww6f.

Is CVE-2014-0110 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free