CVE-2014-0111 Apache Syncope JEXL Code Injection

Medium 6.5 Published Updated

Remote administrators can execute arbitrary Java code in Apache Syncope via JEXL expressions in schema definitions and templates.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-0111?

CVE-2014-0111 is a medium-severity code injection vulnerability in n/a, published on 17 Apr 2014. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Apache Syncope 1.0.0 before 1.0.9 and 1.1.0 before 1.1.7 allows remote administrators to execute arbitrary Java code via vectors related to Apache Commons JEXL expressions, "derived schema definition," "user / role templates," and "account links of resource mappings."

Weakness: CWE-94

Which versions are affected by CVE-2014-0111?

4 open source packages ship an affected version, including org.apache.syncope:syncope. It affects 1 product.

PackageAffectedFixed in
org.apache.syncope:syncope MavenFrom 1.0.01.0.9
org.apache.syncope:syncope MavenFrom 1.0.01.0.9
org.apache.syncope:syncope MavenFrom 1.1.01.1.7
org.apache.syncope:syncope MavenFrom 1.1.01.1.7

Products include Apache Syncope.

How do I fix CVE-2014-0111?

Upgrade org.apache.syncope:syncope to a fixed version for your release line: 1.0.9 or 1.1.7.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2014-0111 being exploited?

There is no known exploitation of CVE-2014-0111 in the wild and no public exploit code.

Sources

Also known as GHSA-r2xf-w5pj-9pw8.

Is CVE-2014-0111 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free