# CVE-2014-0111: Apache Syncope JEXL Code Injection

> Remote administrators can execute arbitrary Java code in Apache Syncope via JEXL expressions in schema definitions and templates.

- **Severity:** Medium 6.5 (`AV:N/AC:L/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-r2xf-w5pj-9pw8

## What is CVE-2014-0111?

CVE-2014-0111 is a medium-severity code injection vulnerability in n/a, published on 17 Apr 2014. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Apache Syncope 1.0.0 before 1.0.9 and 1.1.0 before 1.1.7 allows remote administrators to execute arbitrary Java code via vectors related to Apache Commons JEXL expressions, "derived schema definition," "user / role templates," and "account links of resource mappings."

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2014-0111?

4 open source packages ship an affected version, including org.apache.syncope:syncope. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.syncope:syncope` | Maven | From 1.0.0 | 1.0.9 |
| `org.apache.syncope:syncope` | Maven | From 1.0.0 | 1.0.9 |
| `org.apache.syncope:syncope` | Maven | From 1.1.0 | 1.1.7 |
| `org.apache.syncope:syncope` | Maven | From 1.1.0 | 1.1.7 |

Products: Apache Syncope.

## How do I fix CVE-2014-0111?

Upgrade org.apache.syncope:syncope to a fixed version for your release line: 1.0.9 or 1.1.7.

## Is CVE-2014-0111 being exploited?

There is no known exploitation of CVE-2014-0111 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-53405](https://insights.sbomify.com/CVE-2026-53405/): Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask (critical 9.8)
- [CVE-2026-53421](https://insights.sbomify.com/CVE-2026-53421/): Apache Syncope: Remote Code Execution via Scripted Connector (critical 9.8)
- [CVE-2026-57308](https://insights.sbomify.com/CVE-2026-57308/): Apache Syncope: SQL injection vulnerability in Audit Events search (critical 9.8)
- [CVE-2026-62183](https://insights.sbomify.com/CVE-2026-62183/): Apache Syncope: User self-service privilege escalation (critical 9.8)
- [CVE-2026-63071](https://insights.sbomify.com/CVE-2026-63071/): Apache Syncope: RCE via Groovy Sandbox bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0111 and fix it if it is affected.

What it is: CVE-2014-0111 is a medium-severity code injection vulnerability in n/a, published on 17 Apr 2014. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0111 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.syncope:syncope (Maven): affected from 1.0.0; fixed in 1.0.9
- org.apache.syncope:syncope (Maven): affected from 1.0.0; fixed in 1.0.9
- org.apache.syncope:syncope (Maven): affected from 1.1.0; fixed in 1.1.7
- org.apache.syncope:syncope (Maven): affected from 1.1.0; fixed in 1.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0111/ (Markdown: https://insights.sbomify.com/CVE-2014-0111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0111
- OSV: https://osv.dev/vulnerability/CVE-2014-0111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0111/
Summaries are generated and may contain mistakes; the official description above is the record.
