# CVE-2014-0114: Arbitrary code execution in Apache Commons BeanUtils

> Remote attackers can execute arbitrary code by manipulating the ClassLoader via the class parameter in Apache Commons BeanUtils.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2014
- **Updated:** 14 Oct 2026
- **Also known as:** CLSA-2026-1779756520, CLSA-2026-1788757862, CLSA-2026-1792010669, CLSA-2026-1793128163, CVE-2014-3540, CVE-2014-3893, DEBIAN-CVE-2014-0114, DLA-57-1, DSA-2940-1, ECHO-ced5-f72a-56b5, GHSA-p66x-2cv9-qq3v, MGASA-2014-0219, RHSA-2014:0474, RHSA-2014:0500, ROOT-APP-MAVEN-CVE-2014-0114, UBUNTU-CVE-2014-0114

## What is CVE-2014-0114?

CVE-2014-0114 is a high-severity code injection vulnerability in Apache Struts, published on 30 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Commons BeanUtils, as distributed in lib/commons-beanutils-1.8.0.jar in Apache Struts 1.x through 1.3.10 and in other products requiring commons-beanutils through 1.9.2, does not suppress the class property, which allows remote attackers to "manipulate" the ClassLoader and execute arbitrary code via the class parameter, as demonstrated by the passing of this parameter to the getClass method of the ActionForm object in Struts 1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-0114?

2 open source packages ship an affected version, including commons-beanutils:commons-beanutils. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `commons-beanutils:commons-beanutils` | Maven | From 1.8.0 | 1.9.4 |
| `commons-beanutils:commons-beanutils` | Maven | From 1.8.0 | 1.9.4 |
| `struts` | Red Hat:enterprise_linux:5::client_workstation | All versions | 0:1.2.9-4jpp.8.el5_10 |
| `struts-debuginfo` | Red Hat:enterprise_linux:5::client_workstation | All versions | 0:1.2.9-4jpp.8.el5_10 |
| `struts-javadoc` | Red Hat:enterprise_linux:5::client_workstation | All versions | 0:1.2.9-4jpp.8.el5_10 |
| `struts-manual` | Red Hat:enterprise_linux:5::client_workstation | All versions | 0:1.2.9-4jpp.8.el5_10 |
| `struts-webapps-tomcat5` | Red Hat:enterprise_linux:5::client_workstation | All versions | 0:1.2.9-4jpp.8.el5_10 |
| `struts` | Red Hat:enterprise_linux:5::server | All versions | 0:1.2.9-4jpp.8.el5_10 |
| `struts-debuginfo` | Red Hat:enterprise_linux:5::server | All versions | 0:1.2.9-4jpp.8.el5_10 |
| `struts-javadoc` | Red Hat:enterprise_linux:5::server | All versions | 0:1.2.9-4jpp.8.el5_10 |
| `struts-manual` | Red Hat:enterprise_linux:5::server | All versions | 0:1.2.9-4jpp.8.el5_10 |
| `struts-webapps-tomcat5` | Red Hat:enterprise_linux:5::server | All versions | 0:1.2.9-4jpp.8.el5_10 |
| `struts` | Red Hat:network_satellite:5.4::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-core` | Red Hat:network_satellite:5.4::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-extras` | Red Hat:network_satellite:5.4::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-taglib` | Red Hat:network_satellite:5.4::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-tiles` | Red Hat:network_satellite:5.4::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts` | Red Hat:network_satellite:5.5::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-core` | Red Hat:network_satellite:5.5::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-extras` | Red Hat:network_satellite:5.5::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-taglib` | Red Hat:network_satellite:5.5::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-tiles` | Red Hat:network_satellite:5.5::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts` | Red Hat:network_satellite:5.6::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-core` | Red Hat:network_satellite:5.6::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-extras` | Red Hat:network_satellite:5.6::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-taglib` | Red Hat:network_satellite:5.6::el6 | All versions | 0:1.3.10-6.ep5.el6 |
| `struts-tiles` | Red Hat:network_satellite:5.6::el6 | All versions | 0:1.3.10-6.ep5.el6 |

Products: Apache Commons Beanutils, Apache Struts.

## How do I fix CVE-2014-0114?

Upgrade commons-beanutils:commons-beanutils to 1.9.4 or later.

## Is CVE-2014-0114 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-0114 exists.

Public exploit code:

- A request parameter filter solution for Struts 1 CVE-2014-0114 based on the work of Alvaro Munoz and the HP Fortify team (github_poc): https://github.com/rgielen/struts1filter
- https://github.com/aenlr/strutt-cve-2014-0114 (github_poc): https://github.com/aenlr/strutt-cve-2014-0114
- struts1 CVE-2014-0114 classLoader manipulation vulnerability patch (github_poc): https://github.com/ricedu/struts1-patch
- Apache Struts < 1.3.10 / < 2.3.16.2 - ClassLoader Manipulation Remote Code Execution (Metasploit) (exploitdb)
- Apache Struts ClassLoader Manipulation Remote Code Execution (metasploit)

## Other vulnerabilities in Apache Struts

- [CVE-2025-48734](https://insights.sbomify.com/CVE-2025-48734/): Apache Commons BeanUtils: PropertyUtilsBean does not suppresses an enum's declaredClass property by default (high 8.8)
- [CVE-2019-10086](https://insights.sbomify.com/CVE-2019-10086/): Insecure Deserialization in Apache Commons Beanutils (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0114 and fix it if it is affected.

What it is: CVE-2014-0114 is a high-severity code injection vulnerability in Apache Struts, published on 30 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-0114 exists.

Affected packages and fixed versions:
- commons-beanutils:commons-beanutils (Maven): affected from 1.8.0; fixed in 1.9.4
- commons-beanutils:commons-beanutils (Maven): affected from 1.8.0; fixed in 1.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0114/ (Markdown: https://insights.sbomify.com/CVE-2014-0114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0114
- OSV: https://osv.dev/vulnerability/CVE-2014-0114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0114/
Summaries are generated and may contain mistakes; the official description above is the record.
