{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-0116 in the wild and no public exploit code.","fix":"Upgrade org.apache.struts:struts2-core to 2.3.20 or later.","what":"CVE-2014-0116 is a medium-severity code injection vulnerability in Apache Struts, published on 8 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0116 and fix it if it is affected.\n\nWhat it is: CVE-2014-0116 is a medium-severity code injection vulnerability in Apache Struts, published on 8 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-0116 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.3.20\n- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.3.20\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0116/ (Markdown: https://insights.sbomify.com/CVE-2014-0116/index.md)","id":"CVE-2014-0116","markdown":"https://insights.sbomify.com/CVE-2014-0116/index.md","name":"CVE-2014-0116","record":{"aliases":["GHSA-hmhq-382q-mp56"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Struts framework","requires_auth":"none","summary":"Remote attackers can manipulate the ClassLoader and modify session state via crafted requests when wildcard cookiesName is used in Apache Struts.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"struts","vendor":"apache"}],"cvss":{"score":5.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"CookieInterceptor in Apache Struts 2.x before 2.3.20, when a wildcard cookiesName value is used, does not properly restrict access to the getClass method, which allows remote attackers to \"manipulate\" the ClassLoader and modify session state via a crafted request. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-0113.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ClassLoader manipulation in Apache Struts","id":"CVE-2014-0116","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:struts","products":["apache:struts"],"type":"code_injection","year":"2014"},"n_packages":2,"n_references":5,"next":{"headline":"Denial of service in n/a","id":"CVE-2014-0117"},"packages":[{"ecosystem":"Maven","fixed":["2.3.20"],"introduced":["0"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":null,"source":"GHSA-hmhq-382q-mp56"},{"ecosystem":"Maven","fixed":["2.3.20"],"introduced":["0"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":"pkg:maven/org.apache.struts/struts2-core","source":"GHSA-hmhq-382q-mp56"}],"prev":{"headline":"Apache Storm log viewer path traversal vulnerability","id":"CVE-2014-0115"},"products":["n/a"],"published":"2014-05-08","related":[{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2020-17530","kev_date_added":"2021-11-03","published":"2020-12-11"},{"cvss_score":9.8,"headline":"Apache Struts 1 Improper Input Validation","id":"CVE-2017-9791","kev_date_added":"2022-02-10","published":"2017-07-10"},{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2017-5638","kev_date_added":"2021-11-03","published":"2017-03-11"},{"cvss_score":9.8,"headline":"Apache Struts 2 Improper Input Validation","id":"CVE-2012-0391","kev_date_added":"2022-01-21","published":"2012-01-08"},{"cvss_score":8.1,"headline":"Apache Struts Remote Code Execution","id":"CVE-2018-11776","kev_date_added":"2021-11-03","published":"2018-08-22"},{"cvss_score":8.1,"headline":"Apache Struts Deserialization of Untrusted Data","id":"CVE-2017-9805","kev_date_added":"2021-11-03","published":"2017-09-15"},{"cvss_score":8.1,"headline":"Apache Struts Command Injection","id":"CVE-2016-3081","kev_date_added":"2026-10-08","published":"2016-04-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can manipulate the ClassLoader and modify session state via crafted requests when wildcard cookiesName is used in Apache Struts.","url":"https://insights.sbomify.com/CVE-2014-0116/"}