CVE-2014-0122 Moodle allows bypass of intended access restrictions
Authenticated users can bypass chat access restrictions by remaining in a session after administrator revokes their permissions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-0122?
CVE-2014-0122 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 22 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
mod/chat/chat_ajax.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 does not properly check for the mod/chat:chat capability during chat sessions, which allows remote authenticated users to bypass intended access restrictions in opportunistic circumstances by remaining in a chat session after an intra-session capability removal by an administrator.
Weakness: CWE-264
Which versions are affected by CVE-2014-0122?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.4.9 |
moodle/moodle Packagist | All versions | 2.4.9 |
moodle/moodle Packagist | From 2.5.0 | 2.5.5 |
moodle/moodle Packagist | From 2.5.0 | 2.5.5 |
moodle/moodle Packagist | From 2.6.0 | 2.6.2 |
moodle/moodle Packagist | From 2.6.0 | 2.6.2 |
Products include Moodle Moodle.
How do I fix CVE-2014-0122?
Upgrade moodle/moodle to a fixed version for your release line: 2.4.9, 2.5.5 or 2.6.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2014-0122 being exploited?
There is no known exploitation of CVE-2014-0122 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-f9m9-494r-w36p.