CVE-2014-0123 Moodle does not properly restrict access
Authenticated students can bypass access controls to view and edit other users' wikis via the Recent Activity block.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-0123?
CVE-2014-0123 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 22 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The wiki subsystem in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 does not properly restrict (1) view and (2) edit access, which allows remote authenticated users to perform wiki operations by leveraging the student role and using the Recent Activity block to reach the individual wiki of an arbitrary student.
Weakness: CWE-264
Which versions are affected by CVE-2014-0123?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.4.9 |
moodle/moodle Packagist | All versions | 2.4.9 |
moodle/moodle Packagist | From 2.5.0 | 2.5.5 |
moodle/moodle Packagist | From 2.5.0 | 2.5.5 |
moodle/moodle Packagist | From 2.6.0 | 2.6.2 |
moodle/moodle Packagist | From 2.6.0 | 2.6.2 |
Products include Moodle Moodle.
How do I fix CVE-2014-0123?
Upgrade moodle/moodle to a fixed version for your release line: 2.4.9, 2.5.5 or 2.6.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2014-0123 being exploited?
There is no known exploitation of CVE-2014-0123 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-2vhr-4mhq-m35c.