CVE-2014-0124 Moodle allows attackers to obtain sensitive information

Medium 4.0 Published Updated

Authenticated users can view other users' email addresses via Forum or Quiz modules, exposing sensitive personal information.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-0124?

CVE-2014-0124 is a medium-severity vulnerability in Moodle Moodle, published on 22 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The identity-reporting implementations in mod/forum/renderer.php and mod/quiz/override_form.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 do not properly restrict the display of e-mail addresses, which allows remote authenticated users to obtain sensitive information by using the (1) Forum or (2) Quiz module.

Weakness: CWE-264

Which versions are affected by CVE-2014-0124?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.4.9
moodle/moodle PackagistAll versions2.4.9
moodle/moodle PackagistFrom 2.5.02.5.5
moodle/moodle PackagistFrom 2.5.02.5.5
moodle/moodle PackagistFrom 2.6.02.6.2
moodle/moodle PackagistFrom 2.6.02.6.2

Products include Moodle Moodle.

How do I fix CVE-2014-0124?

Upgrade moodle/moodle to a fixed version for your release line: 2.4.9, 2.5.5 or 2.6.2.

Is CVE-2014-0124 being exploited?

There is no known exploitation of CVE-2014-0124 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-fc5p-vj3h-x7g4.

Is CVE-2014-0124 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free