CVE-2014-0125 Moodle places a session key in a URL

Medium 5.8 Published Updated

Remote attackers can bypass Alfresco file restrictions and impersonate owners by exploiting session keys exposed in URLs within Moodle.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-0125?

CVE-2014-0125 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 22 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

repository/alfresco/lib.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 places a session key in a URL, which allows remote attackers to bypass intended Alfresco Repository file restrictions by impersonating a file's owner.

Weakness: CWE-264

Which versions are affected by CVE-2014-0125?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.4.9
moodle/moodle PackagistAll versions2.4.9
moodle/moodle PackagistFrom 2.5.02.5.5
moodle/moodle PackagistFrom 2.5.02.5.5
moodle/moodle PackagistFrom 2.6.02.6.2
moodle/moodle PackagistFrom 2.6.02.6.2

Products include Moodle Moodle.

How do I fix CVE-2014-0125?

Upgrade moodle/moodle to a fixed version for your release line: 2.4.9, 2.5.5 or 2.6.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2014-0125 being exploited?

There is no known exploitation of CVE-2014-0125 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-j465-7mp6-3xg3.

Is CVE-2014-0125 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free