{"answers":{"affected":"6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-0125 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 2.4.9, 2.5.5 or 2.6.2.","what":"CVE-2014-0125 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 22 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0125 and fix it if it is affected.\n\nWhat it is: CVE-2014-0125 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 22 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-0125 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; fixed in 2.4.9\n- moodle/moodle (Packagist): affected all versions; fixed in 2.4.9\n- moodle/moodle (Packagist): affected from 2.5.0; fixed in 2.5.5\n- moodle/moodle (Packagist): affected from 2.5.0; fixed in 2.5.5\n- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.2\n- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0125/ (Markdown: https://insights.sbomify.com/CVE-2014-0125/index.md)","id":"CVE-2014-0125","markdown":"https://insights.sbomify.com/CVE-2014-0125/index.md","name":"CVE-2014-0125","record":{"aliases":["GHSA-j465-7mp6-3xg3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Remote attackers can bypass Alfresco file restrictions and impersonate owners by exploiting session keys exposed in URLs within Moodle.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":5.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"repository/alfresco/lib.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 places a session key in a URL, which allows remote attackers to bypass intended Alfresco Repository file restrictions by impersonating a file's owner.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle places a session key in a URL","id":"CVE-2014-0125","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"auth_bypass","year":"2014"},"n_packages":6,"n_references":3,"next":{"headline":"Moodle cross-site request forgery (CSRF) vulnerability","id":"CVE-2014-0126"},"packages":[{"ecosystem":"Packagist","fixed":["2.4.9"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-j465-7mp6-3xg3"},{"ecosystem":"Packagist","fixed":["2.4.9"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-j465-7mp6-3xg3"},{"ecosystem":"Packagist","fixed":["2.5.5"],"introduced":["2.5.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-j465-7mp6-3xg3"},{"ecosystem":"Packagist","fixed":["2.5.5"],"introduced":["2.5.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-j465-7mp6-3xg3"},{"ecosystem":"Packagist","fixed":["2.6.2"],"introduced":["2.6.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-j465-7mp6-3xg3"},{"ecosystem":"Packagist","fixed":["2.6.2"],"introduced":["2.6.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-j465-7mp6-3xg3"}],"prev":{"headline":"Moodle allows attackers to obtain sensitive information","id":"CVE-2014-0124"},"products":["n/a"],"published":"2014-03-22","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass Alfresco file restrictions and impersonate owners by exploiting session keys exposed in URLs within Moodle.","url":"https://insights.sbomify.com/CVE-2014-0125/"}