# CVE-2014-0125: Moodle places a session key in a URL

> Remote attackers can bypass Alfresco file restrictions and impersonate owners by exploiting session keys exposed in URLs within Moodle.

- **Severity:** Medium 5.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Mar 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-j465-7mp6-3xg3

## What is CVE-2014-0125?

CVE-2014-0125 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 22 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

repository/alfresco/lib.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 places a session key in a URL, which allows remote attackers to bypass intended Alfresco Repository file restrictions by impersonating a file's owner.

Weakness: CWE-264

## Which versions are affected by CVE-2014-0125?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 2.4.9 |
| `moodle/moodle` | Packagist | All versions | 2.4.9 |
| `moodle/moodle` | Packagist | From 2.5.0 | 2.5.5 |
| `moodle/moodle` | Packagist | From 2.5.0 | 2.5.5 |
| `moodle/moodle` | Packagist | From 2.6.0 | 2.6.2 |
| `moodle/moodle` | Packagist | From 2.6.0 | 2.6.2 |

Products: Moodle Moodle.

## How do I fix CVE-2014-0125?

Upgrade moodle/moodle to a fixed version for your release line: 2.4.9, 2.5.5 or 2.6.2.

## Is CVE-2014-0125 being exploited?

There is no known exploitation of CVE-2014-0125 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0125 and fix it if it is affected.

What it is: CVE-2014-0125 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 22 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0125 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 2.4.9
- moodle/moodle (Packagist): affected all versions; fixed in 2.4.9
- moodle/moodle (Packagist): affected from 2.5.0; fixed in 2.5.5
- moodle/moodle (Packagist): affected from 2.5.0; fixed in 2.5.5
- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.2
- moodle/moodle (Packagist): affected from 2.6.0; fixed in 2.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0125/ (Markdown: https://insights.sbomify.com/CVE-2014-0125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0125
- OSV: https://osv.dev/vulnerability/CVE-2014-0125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0125/
Summaries are generated and may contain mistakes; the official description above is the record.
