CVE-2014-0126 Moodle cross-site request forgery (CSRF) vulnerability
Remote attackers can hijack administrator sessions to import IMS Enterprise files via CSRF in Moodle.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-0126?
CVE-2014-0126 is a medium-severity vulnerability in Moodle Moodle, published on 22 Mar 2014. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Cross-site request forgery (CSRF) vulnerability in enrol/imsenterprise/importnow.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 allows remote attackers to hijack the authentication of administrators for requests that import an IMS Enterprise file.
Weakness: CWE-352
Which versions are affected by CVE-2014-0126?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.4.9 |
moodle/moodle Packagist | All versions | 2.4.9 |
moodle/moodle Packagist | From 2.5.0 | 2.5.5 |
moodle/moodle Packagist | From 2.5.0 | 2.5.5 |
moodle/moodle Packagist | From 2.6.0 | 2.6.2 |
moodle/moodle Packagist | From 2.6.0 | 2.6.2 |
Products include Moodle Moodle.
How do I fix CVE-2014-0126?
Upgrade moodle/moodle to a fixed version for your release line: 2.4.9, 2.5.5 or 2.6.2.
Is CVE-2014-0126 being exploited?
There is no known exploitation of CVE-2014-0126 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-4wvg-7886-83gv.