{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-0128 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-0128 is a medium-severity denial of service vulnerability in Opensuse Opensuse, published on 14 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0128 and fix it if it is affected.\n\nWhat it is: CVE-2014-0128 is a medium-severity denial of service vulnerability in Opensuse Opensuse, published on 14 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-0128 in the wild and no public exploit code.\n\nAffected product: Opensuse Opensuse. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0128/ (Markdown: https://insights.sbomify.com/CVE-2014-0128/index.md)","id":"CVE-2014-0128","markdown":"https://insights.sbomify.com/CVE-2014-0128/index.md","name":"CVE-2014-0128","record":{"aliases":["GHSA-m2w9-x6qf-9vf9","MGASA-2014-0168","MGASA-2014-0192","RHSA-2014:0597","UBUNTU-CVE-2014-0128"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Squid proxy server","requires_auth":"none","summary":"Remote attackers can cause a denial of service in Squid proxy servers via crafted range requests when SSL-Bump is enabled.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"opensuse","vendor":"opensuse"},{"product":"squid","vendor":"squid-cache"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Squid 3.1 before 3.3.12 and 3.4 before 3.4.4, when SSL-Bump is enabled, allows remote attackers to cause a denial of service (assertion failure) via a crafted range request, related to state management.","ecosystems":["Red Hat:enterprise_linux:6::server","Red Hat:enterprise_linux:6::workstation"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2014-0128","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:opensuse","products":["opensuse:opensuse","squid-cache:squid"],"type":"denial_of_service","year":"2014"},"n_packages":4,"n_references":9,"next":{"headline":"Moodle allows attackers to modify the visibility of a badge","id":"CVE-2014-0129"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:6::server","fixed":["7:3.1.10-20.el6_5.3"],"introduced":["0"],"last_affected":[],"package":"squid","purl":"pkg:rpm/redhat/squid","source":"RHSA-2014:0597"},{"ecosystem":"Red Hat:enterprise_linux:6::server","fixed":["7:3.1.10-20.el6_5.3"],"introduced":["0"],"last_affected":[],"package":"squid-debuginfo","purl":"pkg:rpm/redhat/squid-debuginfo","source":"RHSA-2014:0597"},{"ecosystem":"Red Hat:enterprise_linux:6::workstation","fixed":["7:3.1.10-20.el6_5.3"],"introduced":["0"],"last_affected":[],"package":"squid","purl":"pkg:rpm/redhat/squid","source":"RHSA-2014:0597"},{"ecosystem":"Red Hat:enterprise_linux:6::workstation","fixed":["7:3.1.10-20.el6_5.3"],"introduced":["0"],"last_affected":[],"package":"squid-debuginfo","purl":"pkg:rpm/redhat/squid-debuginfo","source":"RHSA-2014:0597"}],"prev":{"headline":"Moodle's time-validation implementation allows bypassing intended restrictions","id":"CVE-2014-0127"},"products":["n/a"],"published":"2014-04-14","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-5957","kev_date_added":null,"published":"2015-09-28"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0491","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2008-2388","kev_date_added":null,"published":"2008-06-06"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2010-1866","kev_date_added":null,"published":"2010-05-07"},{"cvss_score":9.3,"headline":"Other in n/a","id":"CVE-2015-0492","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2014-0158","kev_date_added":null,"published":"2018-04-10"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2016-4343","kev_date_added":null,"published":"2016-05-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in Squid proxy servers via crafted range requests when SSL-Bump is enabled.","url":"https://insights.sbomify.com/CVE-2014-0128/"}