CVE-2014-0129 Moodle allows attackers to modify the visibility of a badge
Authenticated users can modify the visibility of arbitrary badges due to improper tracking of badge ownership in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-0129?
CVE-2014-0129 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 22 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
badges/mybadges.php in Moodle 2.5.x before 2.5.5 and 2.6.x before 2.6.2 does not properly track the user to whom a badge was issued, which allows remote authenticated users to modify the visibility of an arbitrary badge via unspecified vectors.
Weakness: CWE-264
Which versions are affected by CVE-2014-0129?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.5.0 | 2.5.5 |
moodle/moodle Packagist | From 2.5.0 | 2.5.5 |
moodle/moodle Packagist | From 2.6.0 | 2.6.2 |
moodle/moodle Packagist | From 2.6.0 | 2.6.2 |
Products include Moodle Moodle.
How do I fix CVE-2014-0129?
Upgrade moodle/moodle to a fixed version for your release line: 2.5.5 or 2.6.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2014-0129 being exploited?
There is no known exploitation of CVE-2014-0129 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-5rr5-fxhc-jv64.