{"answers":{"affected":"6 open source packages ship an affected version, including actionpack. It affects 3 products.","exploited":"Yes. Attackers have exploited CVE-2014-0130 in the wild since at least 25 Mar 2022.","fix":"Upgrade actionpack to a fixed version for your release line: 3.2.18, 4.0.5 or 4.1.1. US federal agencies must fix it by 15 Apr 2022.","what":"CVE-2014-0130 is a high-severity path traversal vulnerability in Redhat Enterprise Linux Server, published on 7 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0130 and fix it if it is affected.\n\nWhat it is: CVE-2014-0130 is a high-severity path traversal vulnerability in Redhat Enterprise Linux Server, published on 7 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: Yes. Attackers have exploited CVE-2014-0130 in the wild since at least 25 Mar 2022.\n\nAffected packages and fixed versions:\n- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.18\n- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.18\n- actionpack (RubyGems): affected from 4.0.0; fixed in 4.0.5\n- actionpack (RubyGems): affected from 4.0.0; fixed in 4.0.5\n- actionpack (RubyGems): affected from 4.1.0; fixed in 4.1.1\n- actionpack (RubyGems): affected from 4.1.0; fixed in 4.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0130/ (Markdown: https://insights.sbomify.com/CVE-2014-0130/index.md)","id":"CVE-2014-0130","markdown":"https://insights.sbomify.com/CVE-2014-0130/index.md","name":"CVE-2014-0130","record":{"aliases":["GHSA-6x85-j5j2-27jx","RHSA-2014:0510"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby on Rails","requires_auth":"none","summary":"Remote attackers can read arbitrary files via crafted requests in Ruby on Rails when specific route globbing configurations are enabled.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"subscription_asset_manager","vendor":"redhat"},{"product":"rails","vendor":"rubyonrails"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the implicit-render implementation in Ruby on Rails before 3.2.18, 4.0.x before 4.0.5, and 4.1.x before 4.1.1, when certain route globbing configurations are enabled, allows remote attackers to read arbitrary files via a crafted request.","ecosystems":["Red Hat:rhel_software_collections:1::el6","RubyGems"],"exploits":{"exploitdb":0,"first_seen":"2014-05-08","github_poc":1,"max_poc_stars":18,"metasploit":0,"nuclei":0,"refs":[{"date":"2014-05-08T14:40:36Z","kind":"github_poc","ref":"https://github.com/omarkurt/cve-2014-0130","stars":18,"title":"cve-2014-0130 rails directory traversal vuln"}],"tier":"exploited"},"has_fix":true,"headline":"Ruby on Rails Directory Traversal","id":"CVE-2014-0130","indexable":true,"kev":{"dateAdded":"2022-03-25","dueDate":"2022-04-15","knownRansomwareCampaignUse":"Unknown","product":"Ruby on Rails","requiredAction":"Apply updates per vendor instructions.","vendorProject":"Rails","vulnerabilityName":"Ruby on Rails Directory Traversal Vulnerability"},"kind":"cve","links":{"ecosystem":"RubyGems","product":"redhat:enterprise_linux_server","products":["redhat:enterprise_linux_server","rubyonrails:rails"],"type":"path_traversal","year":"2014"},"n_packages":8,"n_references":4,"next":{"headline":"Use after free in n/a","id":"CVE-2014-0131"},"packages":[{"ecosystem":"RubyGems","fixed":["3.2.18"],"introduced":["3.0.0"],"last_affected":[],"package":"actionpack","purl":null,"source":"GHSA-6x85-j5j2-27jx"},{"ecosystem":"RubyGems","fixed":["3.2.18"],"introduced":["3.0.0"],"last_affected":[],"package":"actionpack","purl":"pkg:gem/actionpack","source":"GHSA-6x85-j5j2-27jx"},{"ecosystem":"RubyGems","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"actionpack","purl":null,"source":"GHSA-6x85-j5j2-27jx"},{"ecosystem":"RubyGems","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"actionpack","purl":"pkg:gem/actionpack","source":"GHSA-6x85-j5j2-27jx"},{"ecosystem":"RubyGems","fixed":["4.1.1"],"introduced":["4.1.0"],"last_affected":[],"package":"actionpack","purl":null,"source":"GHSA-6x85-j5j2-27jx"},{"ecosystem":"RubyGems","fixed":["4.1.1"],"introduced":["4.1.0"],"last_affected":[],"package":"actionpack","purl":"pkg:gem/actionpack","source":"GHSA-6x85-j5j2-27jx"},{"ecosystem":"Red Hat:rhel_software_collections:1::el6","fixed":["1:3.2.8-5.5.el6"],"introduced":["0"],"last_affected":[],"package":"ruby193-rubygem-actionpack","purl":"pkg:rpm/redhat/ruby193-rubygem-actionpack","source":"RHSA-2014:0510"},{"ecosystem":"Red Hat:rhel_software_collections:1::el6","fixed":["1:3.2.8-5.5.el6"],"introduced":["0"],"last_affected":[],"package":"ruby193-rubygem-actionpack-doc","purl":"pkg:rpm/redhat/ruby193-rubygem-actionpack-doc","source":"RHSA-2014:0510"}],"prev":{"headline":"Moodle allows attackers to modify the visibility of a badge","id":"CVE-2014-0129"},"products":["n/a"],"published":"2014-05-07","related":[{"cvss_score":9.8,"headline":"Katello uses hard coded credential","id":"CVE-2012-3503","kev_date_added":null,"published":"2012-08-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"active","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-22","vendors":["n/a"]},"summary":"Remote attackers can read arbitrary files via crafted requests in Ruby on Rails when specific route globbing configurations are enabled.","url":"https://insights.sbomify.com/CVE-2014-0130/"}