# CVE-2014-0130: Ruby on Rails Directory Traversal

> Remote attackers can read arbitrary files via crafted requests in Ruby on Rails when specific route globbing configurations are enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Yes, since 25 Mar 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2014
- **Updated:** 22 Oct 2025
- **Also known as:** GHSA-6x85-j5j2-27jx, RHSA-2014:0510

## What is CVE-2014-0130?

CVE-2014-0130 is a high-severity path traversal vulnerability in Redhat Enterprise Linux Server, published on 7 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the implicit-render implementation in Ruby on Rails before 3.2.18, 4.0.x before 4.0.5, and 4.1.x before 4.1.1, when certain route globbing configurations are enabled, allows remote attackers to read arbitrary files via a crafted request.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2014-0130?

6 open source packages ship an affected version, including actionpack. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 3.0.0 | 3.2.18 |
| `actionpack` | RubyGems | From 3.0.0 | 3.2.18 |
| `actionpack` | RubyGems | From 4.0.0 | 4.0.5 |
| `actionpack` | RubyGems | From 4.0.0 | 4.0.5 |
| `actionpack` | RubyGems | From 4.1.0 | 4.1.1 |
| `actionpack` | RubyGems | From 4.1.0 | 4.1.1 |
| `ruby193-rubygem-actionpack` | Red Hat:rhel_software_collections:1::el6 | All versions | 1:3.2.8-5.5.el6 |
| `ruby193-rubygem-actionpack-doc` | Red Hat:rhel_software_collections:1::el6 | All versions | 1:3.2.8-5.5.el6 |

Products: Redhat Enterprise Linux Server, Redhat Subscription Asset Manager, Rubyonrails Rails.

## How do I fix CVE-2014-0130?

Upgrade actionpack to a fixed version for your release line: 3.2.18, 4.0.5 or 4.1.1. US federal agencies must fix it by 15 Apr 2022.

## Is CVE-2014-0130 being exploited?

Yes. Attackers have exploited CVE-2014-0130 in the wild since at least 25 Mar 2022.

Public exploit code:

- cve-2014-0130 rails directory traversal vuln (github_poc): https://github.com/omarkurt/cve-2014-0130

## Other vulnerabilities in Redhat Enterprise Linux Server

- [CVE-2012-3503](https://insights.sbomify.com/CVE-2012-3503/): Katello uses hard coded credential (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0130 and fix it if it is affected.

What it is: CVE-2014-0130 is a high-severity path traversal vulnerability in Redhat Enterprise Linux Server, published on 7 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2014-0130 in the wild since at least 25 Mar 2022.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.18
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.18
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.0.5
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.0.5
- actionpack (RubyGems): affected from 4.1.0; fixed in 4.1.1
- actionpack (RubyGems): affected from 4.1.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0130/ (Markdown: https://insights.sbomify.com/CVE-2014-0130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0130
- OSV: https://osv.dev/vulnerability/CVE-2014-0130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0130/
Summaries are generated and may contain mistakes; the official description above is the record.
