# CVE-2014-0134: OpenStack Nova host data leak to vm instance in rescue mode

> Authenticated users can read compute host files by overwriting instance disks with crafted images when use_cow_images is disabled.

- **Severity:** Low 3.5 (`AV:N/AC:M/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-0134, GHSA-w429-xc55-hc48, PYSEC-2014-112, RHSA-2014:0578

## What is CVE-2014-0134?

CVE-2014-0134 is a low-severity vulnerability in n/a, published on 8 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The instance rescue mode in OpenStack Compute (Nova) 2013.2 before 2013.2.3 and Icehouse before 2014.1, when using libvirt to spawn images and use_cow_images is set to false, allows remote authenticated users to read certain compute host files by overwriting an instance disk with a crafted image.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-0134?

3 open source packages ship an affected version, including nova. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nova` | PyPI | All versions | 12.0.0a0 |
| `nova` | PyPI | All versions | 12.0.0a0 |
| `nova` | PyPI | All versions | 12.0.0a0 |
| `openstack-nova` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-api` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-cells` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-cert` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-common` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-compute` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-conductor` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-console` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-doc` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-network` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-novncproxy` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-objectstore` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `openstack-nova-scheduler` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |
| `python-nova` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-7.el6ost |

Products: Openstack Compute.

## How do I fix CVE-2014-0134?

Upgrade nova to 12.0.0a0 or later.

## Is CVE-2014-0134 being exploited?

There is no known exploitation of CVE-2014-0134 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-7130](https://insights.sbomify.com/CVE-2013-7130/): OpenStack Nova Live migration can leak root disk into ephemeral storage (high 7.1)
- [CVE-2014-0167](https://insights.sbomify.com/CVE-2014-0167/): OpenStack Compute (Nova) allows remote authenticated users to gain privileges via API requests (medium 6.0)
- [CVE-2015-2687](https://insights.sbomify.com/CVE-2015-2687/): OpenStack Compute (Nova) Improper Access Control (medium 4.7)
- [CVE-2013-4179](https://insights.sbomify.com/CVE-2013-4179/): OpenStack Compute (Nova) vulnerable to denial of service via XML Entity Expansion attack (medium 4.3)
- [CVE-2012-2654](https://insights.sbomify.com/CVE-2012-2654/): OpenStack Compute (Nova) Improper Input Validation (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0134 and fix it if it is affected.

What it is: CVE-2014-0134 is a low-severity vulnerability in n/a, published on 8 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0134 in the wild and no public exploit code.

Affected packages and fixed versions:
- nova (PyPI): affected all versions; fixed in 12.0.0a0
- nova (PyPI): affected all versions; fixed in 12.0.0a0
- nova (PyPI): affected all versions; fixed in 12.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0134/ (Markdown: https://insights.sbomify.com/CVE-2014-0134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0134
- OSV: https://osv.dev/vulnerability/CVE-2014-0134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0134/
Summaries are generated and may contain mistakes; the official description above is the record.
