CVE-2014-0135 Kafo allows local users to obtain passwords and other sensitive information by reading default_values.yaml
Local attackers can read world-readable configuration files to obtain sensitive passwords and data from Foreman deployments.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-0135?
CVE-2014-0135 is a low-severity vulnerability in n/a, published on 8 May 2014. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Kafo before 0.3.17 and 0.4.x before 0.5.2, as used by Foreman, uses world-readable permissions for default_values.yaml, which allows local users to obtain passwords and other sensitive information by reading the file.
Weakness: CWE-264
Which versions are affected by CVE-2014-0135?
4 open source packages ship an affected version, including kafo. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
kafo RubyGems | All versions | 0.3.17 |
kafo RubyGems | All versions | 0.3.17 |
kafo RubyGems | From 0.4.0 | 0.5.2 |
kafo RubyGems | From 0.4.0 | 0.5.2 |
Products include Theforeman Kafo.
How do I fix CVE-2014-0135?
Upgrade kafo to a fixed version for your release line: 0.3.17 or 0.5.2.
Is CVE-2014-0135 being exploited?
There is no known exploitation of CVE-2014-0135 in the wild and no public exploit code.
Sources
Also known as GHSA-hxvp-655x-xxqv.