{"answers":{"affected":"4 open source packages ship an affected version, including kafo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-0135 in the wild and no public exploit code.","fix":"Upgrade kafo to a fixed version for your release line: 0.3.17 or 0.5.2.","what":"CVE-2014-0135 is a low-severity vulnerability in n/a, published on 8 May 2014. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0135 and fix it if it is affected.\n\nWhat it is: CVE-2014-0135 is a low-severity vulnerability in n/a, published on 8 May 2014. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-0135 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kafo (RubyGems): affected all versions; fixed in 0.3.17\n- kafo (RubyGems): affected all versions; fixed in 0.3.17\n- kafo (RubyGems): affected from 0.4.0; fixed in 0.5.2\n- kafo (RubyGems): affected from 0.4.0; fixed in 0.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0135/ (Markdown: https://insights.sbomify.com/CVE-2014-0135/index.md)","id":"CVE-2014-0135","markdown":"https://insights.sbomify.com/CVE-2014-0135/index.md","name":"CVE-2014-0135","record":{"aliases":["GHSA-hxvp-655x-xxqv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby configuration library","requires_auth":"low_privilege","summary":"Local attackers can read world-readable configuration files to obtain sensitive passwords and data from Foreman deployments.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"kafo","vendor":"theforeman"}],"cvss":{"score":1.9,"severity":"low","source":"nvd","vector":"AV:L/AC:M/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"Kafo before 0.3.17 and 0.4.x before 0.5.2, as used by Foreman, uses world-readable permissions for default_values.yaml, which allows local users to obtain passwords and other sensitive information by reading the file.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kafo allows local users to obtain passwords and other sensitive information by reading default_values.yaml","id":"CVE-2014-0135","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2014"},"n_packages":4,"n_references":1,"next":{"headline":"Other in n/a","id":"CVE-2014-0136"},"packages":[{"ecosystem":"RubyGems","fixed":["0.3.17"],"introduced":["0"],"last_affected":[],"package":"kafo","purl":null,"source":"GHSA-hxvp-655x-xxqv"},{"ecosystem":"RubyGems","fixed":["0.3.17"],"introduced":["0"],"last_affected":[],"package":"kafo","purl":"pkg:gem/kafo","source":"GHSA-hxvp-655x-xxqv"},{"ecosystem":"RubyGems","fixed":["0.5.2"],"introduced":["0.4.0"],"last_affected":[],"package":"kafo","purl":null,"source":"GHSA-hxvp-655x-xxqv"},{"ecosystem":"RubyGems","fixed":["0.5.2"],"introduced":["0.4.0"],"last_affected":[],"package":"kafo","purl":"pkg:gem/kafo","source":"GHSA-hxvp-655x-xxqv"}],"prev":{"headline":"OpenStack Nova host data leak to vm instance in rescue mode","id":"CVE-2014-0134"},"products":["n/a"],"published":"2014-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can read world-readable configuration files to obtain sensitive passwords and data from Foreman deployments.","url":"https://insights.sbomify.com/CVE-2014-0135/"}