{"answers":{"affected":"2 open source packages ship an affected version, including awesome_spawn. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-0156 in the wild and no public exploit code.","fix":"Upgrade awesome_spawn to 1.2.0 or later.","what":"CVE-2014-0156 is a critical command injection vulnerability in awesome_spawn, published on 30 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0156 and fix it if it is affected.\n\nWhat it is: CVE-2014-0156 is a critical command injection vulnerability in awesome_spawn, published on 30 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-0156 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- awesome_spawn (RubyGems): affected all versions; fixed in 1.2.0\n- awesome_spawn (RubyGems): affected all versions; fixed in 1.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0156/ (Markdown: https://insights.sbomify.com/CVE-2014-0156/index.md)","id":"CVE-2014-0156","markdown":"https://insights.sbomify.com/CVE-2014-0156/index.md","name":"CVE-2014-0156","record":{"aliases":["GHSA-qpqw-mc85-qvm9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby awesome_spawn gem","requires_auth":"none","summary":"Attackers can execute arbitrary OS commands via untrusted input in awesome_spawn arguments, requiring an upgrade to the Ruby gem.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"awesomespawn","vendor":"manageiq"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Awesome spawn contains OS command injection vulnerability, which allows execution of additional commands passed to Awesome spawn as arguments. If untrusted input was included in command arguments, attacker could use this flaw to execute arbitrary command.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OS Command Injection in awesome spawn","id":"CVE-2014-0156","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2014"},"n_packages":2,"n_references":2,"next":{"headline":"OpenStack Dashboard (aka Horizon) vulnerable to Cross-site Scripting","id":"CVE-2014-0157"},"packages":[{"ecosystem":"RubyGems","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"awesome_spawn","purl":null,"source":"GHSA-qpqw-mc85-qvm9"},{"ecosystem":"RubyGems","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"awesome_spawn","purl":"pkg:gem/awesome_spawn","source":"GHSA-qpqw-mc85-qvm9"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2014-0155"},"products":["awesome_spawn"],"published":"2022-06-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can execute arbitrary OS commands via untrusted input in awesome_spawn arguments, requiring an upgrade to the Ruby gem.","url":"https://insights.sbomify.com/CVE-2014-0156/"}