# CVE-2014-0156: OS Command Injection in awesome spawn

> Attackers can execute arbitrary OS commands via untrusted input in awesome_spawn arguments, requiring an upgrade to the Ruby gem.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2022
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qpqw-mc85-qvm9

## What is CVE-2014-0156?

CVE-2014-0156 is a critical command injection vulnerability in awesome_spawn, published on 30 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Awesome spawn contains OS command injection vulnerability, which allows execution of additional commands passed to Awesome spawn as arguments. If untrusted input was included in command arguments, attacker could use this flaw to execute arbitrary command.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2014-0156?

2 open source packages ship an affected version, including awesome_spawn. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `awesome_spawn` | RubyGems | All versions | 1.2.0 |
| `awesome_spawn` | RubyGems | All versions | 1.2.0 |

Products: Manageiq Awesomespawn.

## How do I fix CVE-2014-0156?

Upgrade awesome_spawn to 1.2.0 or later.

## Is CVE-2014-0156 being exploited?

There is no known exploitation of CVE-2014-0156 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0156 and fix it if it is affected.

What it is: CVE-2014-0156 is a critical command injection vulnerability in awesome_spawn, published on 30 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0156 in the wild and no public exploit code.

Affected packages and fixed versions:
- awesome_spawn (RubyGems): affected all versions; fixed in 1.2.0
- awesome_spawn (RubyGems): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0156/ (Markdown: https://insights.sbomify.com/CVE-2014-0156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0156
- OSV: https://osv.dev/vulnerability/CVE-2014-0156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0156/
Summaries are generated and may contain mistakes; the official description above is the record.
