# CVE-2014-0162: OpenStack Image Registry and Delivery Service (Glance) Improper Input Validation vulnerability

> Authenticated users with image modification permissions can execute arbitrary commands on OpenStack Glance instances using the Sheepdog backend.

- **Severity:** Medium 6.0 (`AV:N/AC:M/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-0162, GHSA-r7pj-rvwg-vxhr, PYSEC-2026-817, RHSA-2014:0455

## What is CVE-2014-0162?

CVE-2014-0162 is a medium-severity command injection vulnerability in n/a, published on 27 Apr 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Sheepdog backend in OpenStack Image Registry and Delivery Service (Glance) 2013.2 before 2013.2.4 and icehouse before icehouse-rc2 allows remote authenticated users with permission to insert or modify an image to execute arbitrary commands via a crafted location.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-0162?

3 open source packages ship an affected version, including glance. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glance` | PyPI | From 2013.2 | 2013.2.4 |
| `glance` | PyPI | From 2013.2 | 2013.2.4 |
| `glance` | PyPI | From 2013.2 | 2013.2.4 |
| `openstack-glance` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.2-3.el6ost |
| `openstack-glance-doc` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.2-3.el6ost |
| `python-glance` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.2-3.el6ost |

Products: Openstack Icehouse, Openstack Image Registry and Delivery Service \(Glance\).

## How do I fix CVE-2014-0162?

Upgrade glance to 2013.2.4 or later.

## Is CVE-2014-0162 being exploited?

There is no known exploitation of CVE-2014-0162 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0162 and fix it if it is affected.

What it is: CVE-2014-0162 is a medium-severity command injection vulnerability in n/a, published on 27 Apr 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0162 in the wild and no public exploit code.

Affected packages and fixed versions:
- glance (PyPI): affected from 2013.2; fixed in 2013.2.4
- glance (PyPI): affected from 2013.2; fixed in 2013.2.4
- glance (PyPI): affected from 2013.2; fixed in 2013.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0162/ (Markdown: https://insights.sbomify.com/CVE-2014-0162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0162
- OSV: https://osv.dev/vulnerability/CVE-2014-0162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0162/
Summaries are generated and may contain mistakes; the official description above is the record.
