# CVE-2014-0167: OpenStack Compute (Nova) allows remote authenticated users to gain privileges via API requests

> Remote authenticated users can gain privileges by bypassing RBAC policies in OpenStack Compute security group APIs when using non-default configurations.

- **Severity:** Medium 6.0 (`AV:N/AC:M/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-0167, GHSA-p258-xmh3-72pv, PYSEC-2026-878

## What is CVE-2014-0167?

CVE-2014-0167 is a medium-severity missing authorization vulnerability in n/a, published on 15 Apr 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Nova EC2 API security group implementation in OpenStack Compute (Nova) 2013.1 before 2013.2.4 and icehouse before icehouse-rc2 does not enforce RBAC policies for (1) add_rules, (2) remove_rules, (3) destroy, and other unspecified methods in compute/api.py when using non-default policies, which allows remote authenticated users to gain privileges via these API requests.

Weakness: CWE-264

## Which versions are affected by CVE-2014-0167?

3 open source packages ship an affected version, including nova. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nova` | PyPI | From 2013.1.0 | 2013.2.4 |
| `nova` | PyPI | From 2013.1.0 | 2013.2.4 |
| `nova` | PyPI | From 2013.1.0 | 2013.2.4 |

Products: Openstack Compute, Openstack Icehouse.

## How do I fix CVE-2014-0167?

Upgrade nova to 2013.2.4 or later.

## Is CVE-2014-0167 being exploited?

There is no known exploitation of CVE-2014-0167 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-7130](https://insights.sbomify.com/CVE-2013-7130/): OpenStack Nova Live migration can leak root disk into ephemeral storage (high 7.1)
- [CVE-2015-2687](https://insights.sbomify.com/CVE-2015-2687/): OpenStack Compute (Nova) Improper Access Control (medium 4.7)
- [CVE-2013-4179](https://insights.sbomify.com/CVE-2013-4179/): OpenStack Compute (Nova) vulnerable to denial of service via XML Entity Expansion attack (medium 4.3)
- [CVE-2012-2654](https://insights.sbomify.com/CVE-2012-2654/): OpenStack Compute (Nova) Improper Input Validation (medium 4.3)
- [CVE-2013-4185](https://insights.sbomify.com/CVE-2013-4185/): OpenStack Nova Denial of Service in network source security groups (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0167 and fix it if it is affected.

What it is: CVE-2014-0167 is a medium-severity missing authorization vulnerability in n/a, published on 15 Apr 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0167 in the wild and no public exploit code.

Affected packages and fixed versions:
- nova (PyPI): affected from 2013.1.0; fixed in 2013.2.4
- nova (PyPI): affected from 2013.1.0; fixed in 2013.2.4
- nova (PyPI): affected from 2013.1.0; fixed in 2013.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0167/ (Markdown: https://insights.sbomify.com/CVE-2014-0167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0167
- OSV: https://osv.dev/vulnerability/CVE-2014-0167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0167/
Summaries are generated and may contain mistakes; the official description above is the record.
