{"answers":{"affected":"4 open source packages ship an affected version, including github.com/github/hub and hub. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-0177 in the wild and no public exploit code.","fix":"Upgrade github.com/github/hub to 1.12.1 or later.","what":"CVE-2014-0177 is a low-severity path traversal vulnerability in n/a, published on 27 May 2014. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0177 and fix it if it is affected.\n\nWhat it is: CVE-2014-0177 is a low-severity path traversal vulnerability in n/a, published on 27 May 2014. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-0177 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/github/hub (Go): affected all versions; fixed in 1.12.1\n- github.com/github/hub (Go): affected all versions; fixed in 1.12.1\n- hub (RubyGems): affected all versions; fixed in 1.12.1\n- hub (RubyGems): affected all versions; fixed in 1.12.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0177/ (Markdown: https://insights.sbomify.com/CVE-2014-0177/index.md)","id":"CVE-2014-0177","markdown":"https://insights.sbomify.com/CVE-2014-0177/index.md","name":"CVE-2014-0177","record":{"aliases":["GHSA-x5m6-jh4r-34mv","openSUSE-SU-2024:10501-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"hub CLI tool","requires_auth":"none","summary":"Local attackers can overwrite arbitrary files via symlink attacks on temporary patch files in the hub command-line tool.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"hub","vendor":"github"}],"cvss":{"score":3.6,"severity":"low","source":"nvd","vector":"AV:L/AC:L/Au:N/C:N/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-310","name":null}],"description":"The am function in lib/hub/commands.rb in hub before 1.12.1 allows local users to overwrite arbitrary files via a symlink attack on a temporary patch file.","ecosystems":["Go","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Hub Package Arbitrary File Overwrite","id":"CVE-2014-0177","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"path_traversal","year":"2014"},"n_packages":4,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2014-0178"},"packages":[{"ecosystem":"Go","fixed":["1.12.1"],"introduced":["0"],"last_affected":[],"package":"github.com/github/hub","purl":null,"source":"GHSA-x5m6-jh4r-34mv"},{"ecosystem":"Go","fixed":["1.12.1"],"introduced":["0"],"last_affected":[],"package":"github.com/github/hub","purl":"pkg:golang/github.com/github/hub","source":"GHSA-x5m6-jh4r-34mv"},{"ecosystem":"RubyGems","fixed":["1.12.1"],"introduced":["0"],"last_affected":[],"package":"hub","purl":null,"source":"GHSA-x5m6-jh4r-34mv"},{"ecosystem":"RubyGems","fixed":["1.12.1"],"introduced":["0"],"last_affected":[],"package":"hub","purl":"pkg:gem/hub","source":"GHSA-x5m6-jh4r-34mv"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-0176"},"products":["n/a"],"published":"2014-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can overwrite arbitrary files via symlink attacks on temporary patch files in the hub command-line tool.","url":"https://insights.sbomify.com/CVE-2014-0177/"}