CVE-2014-0193 Netty denial of service vulnerability
Remote attackers can cause denial of service via memory consumption in Netty's WebSocket decoder by sending specific frame sequences.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-0193?
CVE-2014-0193 is a medium-severity denial of service vulnerability in Netty Netty, published on 6 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
WebSocket08FrameDecoder in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19 allows remote attackers to cause a denial of service (memory consumption) via a TextWebSocketFrame followed by a long stream of ContinuationWebSocketFrames.
Weakness: CWE-399
Which versions are affected by CVE-2014-0193?
12 open source packages ship an affected version, including io.netty:netty and io.netty:netty-all. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.netty:netty Maven | From 3.6.0.Beta1 | 3.6.9.Final |
io.netty:netty Maven | From 3.6.0.Beta1 | 3.6.9.Final |
io.netty:netty Maven | From 3.7.0.Final | 3.7.1.Final |
io.netty:netty Maven | From 3.7.0.Final | 3.7.1.Final |
io.netty:netty Maven | From 3.8.0.Final | 3.8.2.Final |
io.netty:netty Maven | From 3.8.0.Final | 3.8.2.Final |
6 more packages
io.netty:netty Maven | From 3.9.0.Final | 3.9.1.Final |
io.netty:netty Maven | From 3.9.0.Final | 3.9.1.Final |
io.netty:netty Maven | From 4.0.0.Alpha1 | 4.0.19.Final |
io.netty:netty Maven | From 4.0.0.Alpha1 | 4.0.19.Final |
io.netty:netty-all Maven | From 4.0.0.Alpha1 | 4.0.19.Final |
io.netty:netty-all Maven | From 4.0.0.Alpha1 | 4.0.19.Final |
Products include Netty Netty.
How do I fix CVE-2014-0193?
Upgrade io.netty:netty to a fixed version for your release line: 3.6.9.Final, 3.7.1.Final, 3.8.2.Final or 3.9.1.Final.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2014-0193 being exploited?
There is no known exploitation of CVE-2014-0193 in the wild and no public exploit code.
Other vulnerabilities in Netty Netty
- CVE-2026-75595 Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext
- CVE-2026-75596 Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing
- CVE-2026-59901 Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
- CVE-2026-55851 Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion
- CVE-2026-56745 Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion
Sources
Also known as GHSA-7vpq-g998-qpv7.