# CVE-2014-0204: OpenStack Identity Keystone Improper Privilege Management

> Remote authenticated users can gain unauthorized privileges in OpenStack Keystone due to improper handling of group and user ID collisions.

- **Severity:** Medium 6.5 (`AV:N/AC:L/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-0204, GHSA-c4p9-87h3-7vr4, PYSEC-2026-654

## What is CVE-2014-0204?

CVE-2014-0204 is a medium-severity vulnerability in n/a, published on 3 Nov 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Identity (Keystone) before 2014.1.1 does not properly handle when a role is assigned to a group that has the same ID as a user, which allows remote authenticated users to gain privileges that are assigned to a group with the same ID.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2014-0204?

3 open source packages ship an affected version, including keystone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |

Products: Openstack Keystone.

## How do I fix CVE-2014-0204?

Upgrade keystone to 8.0.0a0 or later.

## Is CVE-2014-0204 being exploited?

There is no known exploitation of CVE-2014-0204 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-12690](https://insights.sbomify.com/CVE-2020-12690/): Insufficient Session Expiration in OpenStack Keystone (high 8.8)
- [CVE-2019-19687](https://insights.sbomify.com/CVE-2019-19687/): OpenStack Keystone Credential Leakage (high 8.8)
- [CVE-2026-43001](https://insights.sbomify.com/CVE-2026-43001/): OpenStack Keystone has an Incorrect Authorization Issue (high 7.9)
- [CVE-2014-2828](https://insights.sbomify.com/CVE-2014-2828/): OpenStack Identity (Keystone) DoS through V3 API authentication chaining (high 7.8)
- [CVE-2021-38155](https://insights.sbomify.com/CVE-2021-38155/): OpenStack Keystone allows information disclosure during account locking (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0204 and fix it if it is affected.

What it is: CVE-2014-0204 is a medium-severity vulnerability in n/a, published on 3 Nov 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0204 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0204/ (Markdown: https://insights.sbomify.com/CVE-2014-0204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0204
- OSV: https://osv.dev/vulnerability/CVE-2014-0204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0204/
Summaries are generated and may contain mistakes; the official description above is the record.
