CVE-2014-0213 Moodle multiple cross-site request forgery (CSRF) vulnerabilities

Medium 6.8 Published Updated

Remote attackers can hijack teacher sessions to perform unauthorized quick-grading actions in Moodle via CSRF.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2014-0213?

CVE-2014-0213 is a medium-severity vulnerability in Moodle Moodle, published on 27 May 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Multiple cross-site request forgery (CSRF) vulnerabilities in mod/assign/locallib.php in the Assignment subsystem in Moodle through 2.3.11, 2.4.x before 2.4.10, 2.5.x before 2.5.6, and 2.6.x before 2.6.3 allow remote attackers to hijack the authentication of teachers for quick-grading requests.

Weakness: CWE-352

Which versions are affected by CVE-2014-0213?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.4.10
moodle/moodle PackagistAll versions2.4.10
moodle/moodle PackagistFrom 2.5.02.5.6
moodle/moodle PackagistFrom 2.5.02.5.6
moodle/moodle PackagistFrom 2.6.02.6.3
moodle/moodle PackagistFrom 2.6.02.6.3

Products include Moodle Moodle.

How do I fix CVE-2014-0213?

Upgrade moodle/moodle to a fixed version for your release line: 2.4.10, 2.5.6 or 2.6.3.

Is CVE-2014-0213 being exploited?

There is no known exploitation of CVE-2014-0213 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-h75f-hjcr-cvh8.

Is CVE-2014-0213 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free